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Aerial Imagery Tool

Manage import and configuration of aerial imagery files

Description

The Aerial Imagery Tool manages the import and configuration of aerial imagery files. RoadRunner
can import geolocated aerial imagery for use as a visual reference and for texture mapping onto
surfaces. Geolocated imagery files can be imported through a variety of common formats, such as
GeoTIFF (.tif, .tiff) and JPEG 2000 (. jp2), which contain the necessary map projection
information to accurately position them on the surface of the Earth.

Refer to the Aerial Image Assets page for a list of the supported file types.

This tool can also be used to import and adjust nongeoreferenced imagery (for example, JPG
screenshots).

Multiple images can be imported for an area to provide full coverage. This might cause some of the
imported maps to overlap in certain regions. The priority of each image can be adjusted to determine
which one takes priority in overlapping areas.

For links and examples about obtaining geographic information system (GIS) data compatible with
RoadRunner, see “GIS Data Resources for RoadRunner”.

Open the Aerial Imagery Tool

On the RoadRunner toolbar, click the Aerial Imagery Tool button:

Examples
Import a Georeferenced Aerial Image

1 Click the Aerial Imagery Tool button.

2 In the Library Browser, navigate to the directory containing the aerial image on page 2-2 file
you want to import. For more details on aerial images, see Aerial Image Assets.

3 Right-click the asset and make sure that the Default Type is set to Aerial Image.

4 Click and drag the asset from the Library Browser into the 3D scene.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the
World Settings Tool.

If the geographic position has already been set, but the imported image is outside of the
maximum range of the scene, an error dialog box appears and cancels the import.




Aerial Imagery Tool

Import a Nongeoreferenced Aerial Image

To correctly display satellite imagery in RoadRunner, the program must know how to position the
image on the Earth. Obtaining satellite imagery that contains geolocation information (by using a
format such as GeoTIFF or JPEG 2000) is strongly recommended. For links and examples about
obtaining GIS data compatible with RoadRunner, see “GIS Data Resources for RoadRunner”.

If your imagery does not have geolocation information, it is possible to manually set geolocation
information using the following steps.

If You Already Know the Projection

If you already know the specific projection to be used (that is, you have a 'proj' or 'wkt' projection
string), you can set it on the file as follows:

Click the Aerial Imagery Tool button.

In the Library Browser, navigate to the directory containing the image file you want to import.
Right-click the file asset and make sure that the Default Type is set to Aerial Image.

Click the Set Custom Projection button in the Attributes pane.

Paste your 'proj' or 'wkt' string into the text field.

Click OK.

Scale the image by adjusting the Resolution to match the meters per pixel of the image.

NounhphWNR

Custom Local Adjustments

Resolution (MetersTexel)

Reset Resolution

8 Click and drag the image asset from the Library Browser into the 3D scene.

If You Do Not Know the Projection

If you do not know the projection, you can experimentally try different projection values on the file.
These instructions apply a Transverse Mercator projection to the file.

These steps enable you to use arbitrary images, such as a screenshot from a separate application.
However, the result will not be highly accurate.

Click the Aerial Imagery Tool button.

In the Library Browser, navigate to the directory containing the image file you want to import.
Right-click the file asset and make sure that the Default Type is set to Aerial Image.

A W N =

Press the Set Custom Projection button in the Attributes pane.
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Determine the latitude and longitude of the center point of your image, then adjust the latitude
and longitude values in the Custom Projection window, beside the Use Transverse Mercator At
button, to match.

Use Tranverse Mercator At: | Lat:

Click Use Transverse Mercator At. Then, click OK.
Scale the image by adjusting the Resolution to match the meters per pixel of the image.
Custom Local Adjustments

Meter Offset

Resolution (MetersTexel)

Reset Resolution

Click and drag the image asset from the Library Browser into the 3D scene.

Remove an Aerial Image

1
2

3

Click the Aerial Imagery Tool button.

Click the aerial image you want to delete. The selected image is highlighted with a red bounding
box.

Press the Delete key or select Edit > Delete from the menu bar.

Adjust the Resolution of the Loaded Aerial Imagery

1
2

Click the Aerial Imagery Tool button.
Under the Global Aerial Imagery Settings in the Attributes pane, adjust the Meters Per Texel
value as desired.

Adjust the Properties of an Aerial Image

1
2
3

Click the Aerial Imagery Tool button.
Click the aerial image you want to edit.
Adjust the aerial image attributes as desired through the Attributes pane.

Note When more than one aerial image overlaps at a location, the system needs to decide which
one to use. Selecting an aerial image and clicking the Push to bottom or Bring to top buttons
in the Attributes pane adjusts a particular image's priority to resolve overlaps.




Aerial Imagery Tool

Assign an Aerial Imagery Material to a Surface

By default, aerial imagery is displayed only as a visual reference. You can optionally apply the aerial
imagery to terrain surfaces by creating a new material and applying it to the surfaces.

Create a New Material

1 Click the Aerial Imagery Tool button. The global aerial imagery settings appear in the
Attributes pane.
2 Press the Generate Material button in the Attributes pane.

This action generates a new image file called "Overlay.png" and a new material file called
Overlay.rrmtl inside the current directory within the Library Browser. It is necessary for the
system to create a new image because the original aerial imagery might be in an incompatible
projection or made up from multiple separate images. The Generate Material operation combines
the multiple aerial images into one final image that can be mapped orthographically to the terrain
surface.

Assign the Material to One or More Surfaces

1 (Click the Surface Tool button.
2 Click and drag the material to assign it to a surface.

Toggle Display of Aerial Imagery

Select View > Aerial Imagery on the menu bar or press the F4 key.

More About

Tips for Aerial Images in Large Areas

RoadRunner renders aerial images with a single texture image. In some cases, the size of the texture
exceeds the maximum size supported by the graphics card and the imagery fail to render. This
situation can be accompanied by an error message similar to this one:

ERROR: Unable to load overlay: Max byte count exceeded. Max: 16k x 16k texels
with 4 channels.

Here are a few tips that can help with handling imagery of large areas.

Ensure Your Workspace Size Is No Larger Than Needed

The portion of the image that is loaded is determined by the Workspace and World Origin settings
in the World Settings Tool. Ensure that your workspace covers only your area of interest.

In particular, if you georeferenced your scene by dragging Aerial Image Assets into the scene, the
scene is centered on the middle of the image. If you care only about a portion of the scene in the
corner of the image, do not just increase the workspace extents. Instead, try one of the following:

* Before dragging in the aerial image, use the World Settings Tool to set your latitudinal and
longitudinal center of interest

» Use the World Settings Toolto move the workspace to the center of interest. Then, adjust the
extents to cover the area of interest. Imagery is loaded only within the workspace extents.
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Decrease the Imagery Sampling Rate

The Meters Per Texel option in the Aerial Imagery Tool controls the sampling rate of the imagery.
Increase this value to enable viewing of larger areas at the expense of lower image quality.

Adjust the Workspace as You Work

If you have high-resolution imagery and want to create a large area, you can adjust the workspace
based on the current area you are working on. For example, you can adjust the workspace to cover
the northwest portion of your area when you need to edit the northwest area. Then, you can adjust
the workspace again when you need to work on the northeast area.

If you use this approach, be sure to increase the workspace to cover your entire area when you
export.

See Also

Introduced in R2020a



Corner Tool

Corner Tool

Adjust shape and materials of junction corners

Description

The Corner Tool is used to adjust the shape and materials of junction corners.

Open the Corner Tool

On the RoadRunner toolbar, click the Corner Tool button:

See Also

Introduced in R2020a
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Cross Section Tool

Manipulate banking, crowning, and curb shapes at road cross-sections

Description

The Cross Section Tool enables you to edit the shape of roads at specified cross-sections to
manipulate banking, crowning, and curb shapes.

By default, all roads have a cross-section defined at the start and the end of the road. Use this tool to
add additional cross-section nodes at arbitrary points along the road. When you modify these cross-
section nodes, either in the scene editing canvas or the 2D Editor, RoadRunner interpolates the
shape between the nodes. You can also use this tool to modify cross-sections imported from
OpenDRIVEP® files.

To modify the banking angle along the full width of the road, use the Road Superelevation Tool. To
modify the sidewalk heights and adjust the height of the curb, use the Sidewalk Height Tool.

Open the Cross Section Tool

On the RoadRunner toolbar, click the Cross Section Tool button:

Examples

Modify Road at Cross-Section
Add crowning, or slight elevation, to a cross-section of a road.

1 Create a straight road segment by using the Road Plan Tool. Zoom in on the center of the road,
and rotate the camera to view the road from the center to one of the road edges.



Cross Section Tool

2 Click the road to select it. Then, click the Road Cross Section Tool button. As you move your
pointer along the road, the road now displays a preview of a flat road cross-section in blue.

3 Create a road cross-section by right-clicking at the approximate center of the road. In the scene
editing canvas, the cross-section is displayed in red.
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The cross-section is also displayed in the 2D Editor.

To modify the position of the cross-section further, either click and drag the cross-section or, in
the Attributes pane, modify the Distance attribute of the cross-section. You cannot move a
cross-section past another cross-section and you cannot move a cross-section past the start or
end of a lane.

4 In the 2D Editor, right-click the center of the cross-section to add an editable node to the cross-
section.
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Cross Section Tool

0.452148% -0.4521

k

Click and drag the center cross-section node up until it has an approximate height of 0.5 meters.
For more precise control over the height of the node, select the node in the 2D Editor and, in the
Attributes pane, set the Height attribute to 0.5.

In the scene editing canvas, the road is now crowned at the inserted cross-section, sloping down
to the left and right of its elevated center.
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6 (Optional) Modify additional parts of the cross-section from the 2D Editor. For example, drag the
node tangents to change the slope of the road at the edges.

The cross-section of the road remains flat at the road edges, and RoadRunner interpolates the height
and slope of the road between the inserted cross-section and the road edges.

Parameters

Road Cross-Section Attributes

Attribute Description

Distance Position of the cross-section along the road, in

meters, specified as a nonnegative real scalar.
Distance is relative to the edge of the road that
was created first.

Cross-Section Node Attributes

Attribute Description

Height Height of node above the ground, in meters,
specified as a real scalar.

Offset Lateral offset of node from the center of the

cross-section, in meters, specified as a real scalar.

Cross-Section Node Tangent Attributes

Attribute Description

Slope Slope of node tangent, in percent grade, specified
as a real scalar.
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Cross-Section Span Attributes

Attribute

Description

Height

Height of span above ground, in meters, specified
as a real scalar.

If the height varies along the span, then the
Height attribute displays the height of the cross-
section node connected to the left side of the
span.

Slope

Slope of span, in percent grade, specified as a
real scalar.

Limitations

* RoadRunner imports superelevation data from OpenDRIVE files but visualizes OpenDRIVE roads
only by interpolating between the specified lane boundary positions. This visualization difference
means that roads shown in the scene editing canvas do not match the superelevation data in the
Cross Section Tool. For example, this imported road renders as having a sharp, triangular slope
whereas the actual superelevation data shows that the road has a more bell-shaped slope.

When you export such roads back to OpenDRIVE, RoadRunner exports the superelevation data so
that the roads maintain their correct analytical representation.

Tips

* You can save a cross-section as a road style template for use with creating future roads. Select a
road cross-section and, in the Attributes pane, click Create Road Style. Save the new road style

template to the Library Browser.

See Also

Road Superelevation Tool | Sidewalk Height Tool
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Introduced in R2020a
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Crosswalk And Stop Line Tool

Crosswalk And Stop Line Tool

Add crosswalks and stop lines between corners at intersections

Description

The Crosswalk and Stop Line Tool can be used to add crosswalks and stop lines between corners at
intersections.

Note Free-form crosswalks can be created using the Marking Curve Tool. Where possible, use the
Crosswalk And Stop Line Tool instead. Crosswalks and stop lines created in this tool have more
semantic linkage to the road topology.

Open the Crosswalk And Stop Line Tool

On the RoadRunner toolbar, click the Crosswalk And Stop Line Tool button:

Examples

Add a Single Crosswalk to a Junction

1 Click the Crosswalk and Stop Line Tool button.

2 Optionally, select a desired crosswalk style in the Library Browser.

3 Click the corner of a junction that you want the crosswalk to start from.

4 Right-click the corner that you want the crosswalk to end at (in the same junction).

Tip If you need to create a standalone crosswalk (that is, a crosswalk along a road that does not
involve an intersection), you can use the Custom Junction Tool to create a junction along a single
road.

You can also create free-form crosswalks anywhere in your scene using the Marking Curve Tool
(with Crosswalk Marking Assets selected). Note that free-form crosswalks might lack certain
export-related functionality.
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Quickly Add All Crosswalks to a Junction

1 Click the Crosswalk and Stop Line Tool button.

2 Check that no junctions are selected.

3 Optionally, select a desired crosswalk style in the Library Browser.
4 Right-click a junction to add crosswalks across each road.

Delete a Crosswalk

1 Click the Crosswalk and Stop Line Tool button.
2 Select a crosswalk.
3 Press the Delete key or select Edit > Delete from the menu bar.

Assign a Style to a Crosswalk

1 Enter the Crosswalk and Stop Line Tool.

2 Select the crosswalk you want to edit.

3 Click and drag Crosswalk Marking Assets from the Library Browser onto the Crosswalk
Style widget in the Attributes pane.

Alternatively, click and drag Crosswalk Marking Assets from the Library Browser onto a
crosswalk in the scene.

Adjust the Location of a Crosswalk

After creating a crosswalk, you can move the locations of the crosswalk's end points (for example, to
create crosswalks that cross a road at an angle).

ey

1 Click the Crosswalk and Stop Line Tool button.
2 Select the crosswalk you want to edit.



Crosswalk And Stop Line Tool

3 Click and drag a point at the end of the crosswalk. Alternatively, adjust the Left Corner Offset
and Right Corner Offset values in the Attributes pane.

Note The points at the end of a crosswalk must lie within the extents of the junction. Note that
you can expand the extents of a junction by extending the corners using the Corner Tool.

Add Stop Lines to a Junction

Preview shows where stop line will appear: The new stop line updates the stopping locations:

1 Click the Crosswalk and Stop Line Tool button.

2  Select the junction you want to edit.
3 Right-click the road at the location where you want to add a new stop line node.

View Stopping Locations for a Junction

Stopping locations are computed for all lanes approaching a junction. Stopping locations define the
starting location of all maneuvers.
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Stopping locations shown as blue chevrons:

To view stopping locations for a junction, follow these steps:

1 Click the Crosswalk and Stop Line Tool button.
2 Select the junction you want to edit.

Stop Line Editing

1 Click the Crosswalk and Stop Line Tool button.
2 Select the junction you want to edit.
3 Stop line editing is similar to marking curves. See Marking Curve Tool for documentation on

how to edit stop lines.
Multiple Stop Lines

Multiple stop lines can be added to a single approach to add unique stopping locations for each lane.
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See Also

Introduced in R2020a
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Custom Junction Tool

Override RoadRunner automatic junction functionality for advanced cases

Description

The Custom Junction Tool is used to override the RoadRunner automatic junction functionality for
advanced cases. It enables the creation of junctions where no overlaps are present. Junctions that are
automatically created by RoadRunner are referred to as automatic junctions. These junctions are
automatically created, updated, and removed as necessary. Junctions that are manually created by
this tool are referred to as locked junctions. These junctions are manually created and must be
manually removed. It is sometimes desirable to convert an automatic junction to a locked junction,
either to add more roads to the junction or to change the default stop locations.

The default stop location represents the start or end of a junction along a road. It is the location
where newly created maneuver roads automatically stop and the default distance where corners

begin. The default stop location has a direction that points out from the junction. This direction is
used for determining which roads need to be connected by using corners.

Open the Custom Junction Tool

On the RoadRunner toolbar, click the Custom Junction Tool button:

Examples

Create a Junction Between Roads That Do Not Overlap

1-20
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1 Click the Custom Junction Tool button.
2 Right-click the end of each road that will be part of the junction.
3 Press Spacebar to create the junction.

Remove a Locked Junction

1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 Press Delete.

Note Removing a locked junction can result in an automatic junction in its place if roads are
overlapping.

Convert an Automatic Junction to a Locked Junction

1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 In the Attributes pane, click Convert to Locked Junction.

Convert a Locked Junction to an Automatic Junction

1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 In the Attributes pane, click Convert to Automatic Junction.

Note A locked junction cannot always be converted to an automatic junction. If no automatic
junction is possible, the junction will be removed during conversion.

Add a Road to a Locked Junction

1 Click the Custom Junction Tool button.

2 Right-click the end of the road to add to the junction.
3 Right-click the junction.

4 Press Spacebar to add the road.

Remove a Road from a Locked Junction

1 Click the Custom Junction Tool button.

2 Click the desired junction.

3 Click the Default Stopline of the road that you want to remove.
4 Press Delete.
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Create a Junction Between Two Parallel Roads

1 Click the Custom Junction Tool button.

2 Right-click at the start of the junction on one road and then the end of the junction on the same
road.

3 Right-click at the start of the junction on the other road and then the end of the junction on the
same road.

4 Press Spacebar to create the junction. If the corners do not appear correctly, see the
“Troubleshooting Locked Junctions” on page 1-23 section.

Merge Two or More Junctions

1 Click the Custom Junction Tool button.

2 Right-click each junction to be merged.

3 Press Spacebar to merge the junctions together.

4 Click any extraneous default stop lines on the inside of the junction and press Delete.
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Create a Junction Along a Single Road

Creating junctions along a single road is useful for creating standalone crosswalks. To create a
junction along a single road:

1 Click the Custom Junction Tool button.

2 Right-click the road at the start of the junction and at the end of the junction. If you are making a
crosswalk, the start and end of the junction roughly correspond to each side of the crosswalk.

3 Press Spacebar to create the junction. If the junction does not appear correctly, see the
“Troubleshooting Locked Junctions” on page 1-23 section.

4 Optionally, if you are making a crosswalk:

1 Click the Crosswalk and Stop Line Tool button.

2 Click the outer side of the junction.
3 Right-click the other side of the junction to create the crosswalk.

Adjust a Default Stop Location

1 Click the Custom Junction Tool button.

2 Click the desired junction.

3 If the junction is automatic, convert the junction to locked.
4 Click and drag the desired stop location.

Change the Direction of a Default Stop Location

1 Click the Custom Junction Tool button.

2 Click the desired junction.

3 Click the desired default stop location.

4 In the Attributes pane, click Flip Direction.

More About

Troubleshooting Locked Junctions

RoadRunner attempts to make a reasonable locked junction based on the specified default stop
locations, but the software might be unable to determine the necessary corners to make a reasonable
junction. Here are a few steps to take if a locked junction's corners are not computed correctly:

* Check that all default stop locations point outward from the junction. If a default stop location has
been placed manually on a road, the initial direction might be flipped.

* Check that the default stop locations are not too close together. Try dragging the locations farther
apart and clicking Sort Rays to redetermine the corners.
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* Try using multiple smaller locked junctions instead of one large one. Remove roads from the
junction as necessary.

* Try using overlaps instead of making the junction manually.

See Also

Introduced in R2020a
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Elevation Map Tool

Manage import and configuration of digital elevation model (DEM) files

Description

The Elevation Map Tool manages the import and configuration of digital elevation model (DEM)
files. RoadRunner can import elevation map data from a variety of file formats, such as DEM, IMG,
JPEG 2000, and TIFE Some of these formats support georeferencing and can be automatically
positioned accordingly.

Refer to the Elevation Map Assets page for a list of the supported file types.

Multiple elevation maps can be imported for an area to provide full coverage. This can cause some of
the imported maps to overlap in certain regions. You can adjust the priority of each map to determine
which one takes priority in overlapping areas.

Open the Elevation Map Tool

On the RoadRunner toolbar, click the Elevation Map Tool button:

J

Examples
Import a Georeferenced Elevation Map

1 Click the Elevation Map Tool button.

2 In the Library Browser, navigate to the directory containing the Elevation Map Assets you
want to import.

3 Right-click the assets and make sure that the Default Type is set to Elevation Map.

4 Click and drag the assets from the Library Browser into the scene editing canvas.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the
World Settings Tool.

If the geographic position has already been set, but the imported image is outside of the
maximum range of the scene, an error dialog box appears and cancels the import.

Import a Nongeoreferenced Elevation Map

To correctly display an elevation map in RoadRunner, the program must know how to position the
map on the Earth. For best accuracy, obtaining elevation data that contains geolocation information
(by using a format such as GeoTIFF or JPEG 2000) is strongly recommended. For links and examples
about obtaining GIS data compatible with RoadRunner, see “GIS Data Resources for RoadRunner”.
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If your elevation map does not have geolocation information, it is possible to manually set geolocation
information using the following steps.

If You Already Know the Projection

If you already know the specific projection to be used (that is, you have a 'proj' or 'wkt' projection
string), you can set it on the file as follows:

1 Click the Elevation Map Tool button.

2 In the Library Browser, navigate to the directory containing the elevation map file you want to
import.

3 Right-click the file asset and make sure that the Default Type is set to Elevation Map.

4 Click the Set Custom Projection button in the Attributes pane.

5 Paste your 'proj' or 'wkt' string into the text field.

6 Click OK.

7 Scale the data by adjusting the Resolution to match the meters per pixel of the elevation map.

Custom Local Adjustments

Meter Offset

Resolution (Meters,Texel)

Reset Resolution

8 Click and drag the elevation map asset from the Library Browser into the 3D scene.

If You Do Not Know the Projection

The following steps enable you to use arbitrary grayscale images for elevation, such as a screenshot
from a separate application. However, the result will not be highly accurate.

If you do not know the projection, you can experimentally try different projection values on the file.
These instructions apply a Transverse Mercator projection to the file.

Click the Elevation Map Tool button.

In the Library Browser, navigate to the directory containing the image file you want to import.
Right-click the file asset and make sure that the Default Type is set to Elevation Map.

Click the Set Custom Projection button in the Attributes pane.

gua A W N R

Determine the latitude and longitude of the center point of your elevation data. Then, adjust the
latitude and longitude values in the Custom Projection window to match.

Use Tranverse Mercator At: | Lat:




Elevation Map Tool

Click Use Transverse Mercator At. Then, click OK.
Scale the data by adjusting the Resolution to match the meters per pixel of the image.

Custom Local Adjustments

Meter Offset

Reset Offset

Resolution (MetersTexel)

Reset Resolution

8 Click and drag the elevation map asset from the Library Browser into the 3D scene.

Remove an Elevation Map

1 Click the Elevation Map Tool button.
2 Click the elevation map you want to delete.
3 Press the Delete key or select Edit > Delete from the menu bar.

Adjust the Properties of an Elevation Map

1 Click the Elevation Map Tool button.
2 Click the elevation map you want to edit.
3 Adjust the elevation map attributes as desired through the Attributes pane.

Note When more than one elevation map overlaps at a location, the system needs to decide
which one to use. Selecting an elevation map and clicking the Push to bottom or Bring to top
buttons in the Attributes pane adjusts a map's priority to resolve overlaps.

Toggle the Display of Elevation Maps

Select View > Elevation from the menu bar, or press F5.

Project Roads and Other Objects to Elevation Maps

Many RoadRunner objects can be projected to an elevation map surface. The specific steps are
documented in the appropriate tools. For example, the steps for projecting roads to elevation maps
can be found here: Project Roads to Elevation Maps on page 1-105.

In most cases, the steps are the same:

1 Select the appropriate tool.

2 Select one more objects in the scene editing canvas.
3 Click the appropriate projection button in the toolbar on the left.
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Include Elevation Maps in Surface Triangulation

By default, the elevation maps are displayed as a white topographic surface. This surface is not
included in the exported scene.

To include the visual influence of the elevation maps in the scene, you must create terrain surfaces
covering the area, and then enable global elevation. For more details on terrain surfaces, see “How
Surfaces Work in RoadRunner”.

For more information, refer to Control Whether a Surface Uses Elevation Samples on page 1-155 .

See Also

Topics
“Create Roads Around Imported GIS Assets”

Introduced in R2020a
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Junction Surface Tool

Control how road elevations and cross-sections influence interior triangulation of intersections

Description

The Junction Surface Tool controls how road elevations and cross-sections influence the interior
triangulation of intersections.

Open the Junction Surface Tool

On the RoadRunner toolbar, click the Junction Surface Tool button:

Examples

View Road Samples Within a Junction

1 Click the Junction Surface Tool button.

2 Select a junction. This selection displays all the individual road surface spans that overlap the
junction.

3 Click a road span. When selected, a road span draws the portion of the road that overlaps the
junction and the samples that it includes.
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Include or Exclude Samples from a Road Span
You can include or exclude samples from specific spans from the triangulation.

1 Click the Junction Surface Tool button.

2 Select a junction. This selection displays all the individual road surface spans that overlap the
junction.

3 Click a road span. When selected, a road span draws the portion of the road that overlaps the
junction and the samples that it includes.

4 Toggle the Include Samples check box in the Attributes pane to include or exclude the
samples.

1-30



Junction Surface Tool

Change the Sorting of Road Span Samples

Sorting one span above another prevents the lower samples from being included.

1 Click the Junction Surface Tool button.

2 Select a junction. This selection displays all the individual road surface spans that overlap the
junction.

3 Click a road span. When selected, a road span draws the portion of the road that overlaps the
junction and the samples that it includes.
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4 Press the Raise or Lower button in the Attributes pane to raise or lower the Sort Index of the
selected road span relative to the others.
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Junction Surface Tool

See Also

Introduced in R2020a
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Lane Add Tool

Add fully formed lane along road

Description
The Lane Add Tool is used to add a fully formed lane along a road.

Note To create a new forming lane or an ending lane, use the Lane Form Tool.

Open the Lane Add Tool

On the RoadRunner toolbar, click the Lane Add Tool button:

Examples
Add a New Lane to a Road

1 Click the Lane Add Tool button.
2 Click the road you want to edit.
3 Select the desired lane type in the Options pane.

Note If the lane type is set to Automatic, then the new lane copies the lane type of the
neighboring lane.

4 Move the pointer near where you want to add a lane until you see a light blue line indicating
where the new lane will be added. If you are pointing near the center reference curve of the
road, you can choose which side of the road the new lane will go by moving the pointer to one
side or the other of the center curve.

Note By default, the new lane will be added only between the two nearest intersections. To
force the new lane to add along the entire road, hold the Ctrl key.




Lane Add Tool

Default
Behavior
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With CTRL-key

5 Right-click to add a new lane.
6 Optionally, you can hold the right-click button down and drag to adjust the width of the new lane.

See Also

Introduced in R2020a
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Lane Carve Tool

Create tapering cut in lane, such as dedicated turn lane in median

Description

The Lane Carve Tool is used to create a tapering cut in a lane, such as the dedicated turn lanes in a
median.

Open the Lane Carve Tool

On the RoadRunner toolbar, click the Lane Carve Tool button:

Examples

Carve a Tapering Cut Into a Lane

1
2
3

Click the Lane Carve Tool button.

Click the road you want to edit.

Move the pointer to where you want to start the carve. The lane highlights and a light blue point
indicates where the carving will start.

Right-click and drag the pointer to carve the lane. You can move up or down the road and left or
right along the lane to determine where the carving ends. A light blue curve indicates where the
carve will take place.

Note A lane cut always starts at the boundary of a lane. It can end either at the opposite side of
the lane or in the middle of the lane.
When you have moved to the desired end location of the carve, release the right-click button.
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Modify the Carve Location After Performing a Carve

If you have performed a lane carve and later want to change where the carve starts or ends, follow
the steps in Move the End of a Lane on page 1-53 and adjust the ends of a lane by using the Lane
Width Tool.

Depending on which end of the carve you are adjusting, you might need to move both the tapered end
of one lane and the width marker on the adjacent lane. These moves can be tricky, but the simplest
approach is to box-select both elements together before dragging. For more details on box-selection,
see “Manipulate Scene Objects”.

This image shows a box selection of two UI elements together. After selecting, you can click and drag
them or adjust the Distance value in the Attributes pane.

Modify the Lane Widths After Performing a Carve

See the Lane Width Tool.
See Also

Introduced in R2020a
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Lane Chop Tool

Cut single lane into two lanes

Description

The Lane Chop Tool can be used to cut a single lane into two lanes at a desired location. Chopping
does not have an immediately visible effect, but it enables you to make instantaneous changes in lane
properties or have lanes start or end abruptly.

Open the Lane Chop Tool

On the RoadRunner toolbar, click the Lane Chop Tool button:

Examples
Chop a Lane

Click the Lane Chop Tool button.

Click the road you want to edit.

Move the mouse cursor to the location you want to chop. You will see a light blue line indicating
where the chop operation will take place.

4 Right-click to chop the lane at the desired location.

WN R

See Also

Introduced in R2020a
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Lane Form Tool

Add forming or ending lane along road

Description

The Lane Form Tool is used to add a forming or ending lane along a road.

Note To create a fully formed lane, use the Lane Add Tool.

Open the Lane Form Tool

On the RoadRunner toolbar, click the Lane Form Tool button:

Examples
Add a New Lane to a Road
Click the Lane Form Tool button.

1
2 Click the road you want to edit.
3  Select the desired lane type in the Options pane.

Note If the lane type is set to Automatic, then the new lane copies the lane type of the
neighboring lane.

4 Move the pointer near where you want to add a lane until you see a light blue line indicating
where the new lane will be added. If you are pointing near the center reference curve of the
road, you can choose which side of the road the new lane will go by moving the pointer to one
side or the other of the center curve.
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By default, the new lane will be added only between the two nearest intersections. To force the
new lane to add along the entire road, hold the Ctrl key.

Default Behavior

I

.I
&

With CTRL-key

g
Right-click and drag outward from the center of the road to create the new lane and adjust the

end of the tapering section.
Optionally, you can drag up or down the length of the road to switch between a forming lane and

an ending lane.
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See Also

Introduced in R2020a
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Lane Marking Tool

Add linear markings to lane boundaries

Description

The Lane Marking Tool adds linear markings to lane boundaries. To assign marking styles to a lane
marking, you must first create some marking styles in the Asset Browser. The RoadRunner sample
project has several common marking styles pre-defined in the Assets/Markings directory. You can
create and modify your own marking styles and add them to the project as well.

Open the Lane Marking Tool

On the RoadRunner toolbar, click the Lane Marking Tool button:

Examples

Create and Modify Lane Markings Along a Lane

See “Span Editing”.

Note Lane marking spans store Lane Marking Assets data, which can be directly dragged onto a
lane span from the Library Browser. This operation works in any tool. The Lane Marking Tool is
activated when the mouse is released.

Parameters

See Marking Curve Tool attributes.
See Also

Introduced in R2020a
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Lane Offset Tool

Adjust location of center lane of road

Description

The Lane Offset Tool is used to adjust the location of the center lane of a road. This tool is nearly
identical to the Lane Width Tool, except that it operates only on the center lane. For more
information on usage, see the Lane Width Tool.

Open the Lane Offset Tool

On the RoadRunner toolbar, click the Lane Offset Tool button:

See Also

Introduced in R2020a
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Lane Split Tool

Split lane lengthwise into two lanes

Description

The Lane Split Tool is used to split a lane lengthwise into two lanes. Splitting a lane automatically
adds a default lane marking that can be changed or removed with the Lane Marking Tool.

Open the Lane Split Tool

On the RoadRunner toolbar, click the Lane Split Tool button:

b ¢!

Examples
Split a Lane Lengthwise

1 Click the Lane Split Tool button.

2  Click the road you want to edit.

3 Move the pointer to the location you want to split. A light blue line indicates where the split
operation will take place.

By default, the lane split affects only the lane between the two nearest intersections. To force the
lane split to occur along the entire road, hold the Ctrl key.
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Default
Behavior

4 Right-click to split the lane.

See Also

Introduced in R2020a
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Lane Tool

Delete lanes and update lane type and travel direction

Description

The Lane Tool is used to delete lanes and make changes to lane attributes, such as the lane type and
travel direction.

Open the Lane Tool

On the RoadRunner toolbar, click the Lane Tool button:

Examples

Change Lane Type

Click the Lane Tool button.

Click the road containing the target lane.

Click a lane to display its attributes. The selected lane is highlighted in red.
Select a lane type in the Attributes pane.

AP WNR

Change Lane Travel Direction

1 Click the Lane Tool button.
2 Click the road containing the target lane.
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3 Click a lane to display its attributes. The selected lane is highlighted in red.
4 Select a travel direction in the Attributes pane.

Delete a Lane

1 Click the Lane Tool button.

2 Click the road containing the target lane.

3 Click a lane.

4 Press the Delete key or select Edit > Delete from the menu bar.

See Also

Introduced in R2020a
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Lane Width Tool

Adjust lane widths along road

Description

The Lane Width Tool is used to adjust lane widths at any location along a road. The width of
individual lanes can be varied across the entire lane or more locally at specified locations. Width
values are stored on lane width markers, which can be positioned independently along lanes. The
width of the lane on the sections between markers is interpolated from the marker widths.

All lanes will automatically have lane width markers at the beginning and end of the lane.

When the Lane Width Tool is selected and a road is highlighted, all the lane width markers for the
road will be displayed.

Note The Lane Width Tool does not allow adjustments to the center lane. To adjust the center lane,
use the Lane Offset Tool.

Open the Lane Width Tool

On the RoadRunner toolbar, click the Lane Width Tool button:
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Examples

Create a New Lane Width Marker

Click the Lane Width Tool button.

Click the road you want to edit.

Move the pointer over the lane where you want to insert the marker. A light blue line appears,
indicating where the marker will be inserted.

Right-click to add a new width marker.

Optionally, press the right-click button and drag to adjust the marker. If you initially right-click
near the lane boundary, you can drag the lane width at the marker. If you initially right-click near
the inside of the lane, you can drag the position of the width marker.

Adjust the Width at a Marker

P WNR

Click the Lane Width Tool button.

Click the road you want to edit. The lane width markers will be displayed on the picked road.
Click and drag the point on the outer boundary of the width marker you want to edit.
Optionally, once the width marker is selected, you can type the desired width directly into the
Width slider in the Attributes pane.



Lane Width Too

Adjust the Width of a Lane Section Between Two Markers

Click the Lane Width Tool button.

Click the road you want to edit. The lane width markers and lane boundary lines are displayed
for the selected road.

Click and drag the lane border curve to move it in or out. The action automatically adjusts the
markers at the start and end of the section.

Optionally, once the lane section is picked, you can type the desired width directly into the Width
slider in the Attributes pane to set the width at the start and end of the lane section.

Adjust the Angle at a Marker

1
2
3
4
5

Click the Lane Width Tool button.

Click the road you want to edit. The lane width markers are displayed on the selected road.
Click a lane width marker. Two new angle points are displayed.

Click and drag an angle point to adjust the slope.

Optionally, once the angle point is picked, you can type the desired slope value directly into the
Slope slider in the Attributes pane.
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Create Sharp Angles

By default, the slope on either side of a lane width marker is kept continuous. You can create sharp
angles by disconnecting the slopes as follows:

1 Click the Lane Width Tool button.

2 Click the road you want to edit. The lane width markers are displayed on the selected road.

3 Click a lane width marker. Two new angle points are displayed.

4 Click the Disconnect Tangents button. The angle points are no longer kept continuous, and you
can control the slopes on either side independently.

Tip When you click Disconnect Tangents, the slopes are always set to point at the next or previous
width marker, even if the slopes are already disconnected.

Remove Sharp Angles
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To convert a sharp angle into a smooth angle at a lane width marker, connect the slopes as follows:

1 Click the Lane Width Tool button.

2 Click the road you want to edit. The lane width markers are displayed on the selected road.
3 Click a lane width marker. Two new angle points are displayed.

4 Click the Connect Tangents button. The angle points are now kept continuous.
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Move a Width Marker

1 Click the Lane Width Tool button.
2  Click the road you want to edit. The lane width markers are displayed on the selected road.
3 Click and drag near the middle of the line of the width marker that you want to move.

Move the End of a Lane

Click the Lane Width Tool button.

Click the road you want to edit. The lane width markers will be displayed on the selected road.
Click and drag the horizontal tick at the end of the lane.

WN R

Note It can be difficult to select the horizontal tick because the UI favors selecting the width
point at the same location. Rather than clicking directly on the tick, move the pointer to the side
of the tick until the tick is highlighted in yellow.

Delete a Width Marker

1 Click the Lane Width Tool button.

2 Click the road you want to edit. The lane width markers and lane boundary lines are displayed on
the selected road.

3 Press the Delete key or select Edit > Delete from the menu bar.

Note You cannot delete the markers at the start or end of the entire lane.
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More About

Stacked and Unstacked Boundaries
Lane boundaries behave differently depending on whether they are stacked or not.

Stacked boundaries are offset from their neighboring lanes. In this way, adjusting a lane boundary
affects all lanes facing outward from the center lane.

When a boundary is not stacked, its width is determined as an offset from the road's center lane, not
its neighboring lanes.

Set Stacked and Unstacked Behavior

Click the Lane Width Tool button.

Click the road containing the target lane.

Click a lane boundary to select it and display its attributes. The selected lane boundary is
highlighted in red.

4 Toggle the Stacked attribute in the Attributes pane.



Lane Width Too

Moving a lane where the outermost boundary is stacked

See Also

Introduced in R2020a
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Maneuver Tool

Manipulate individual maneuver roads (paths) within junction

Description

The Maneuver Tool enables the manipulation of the various individual maneuver roads (paths)
within a junction. These maneuver roads do not affect the geometry of the road model, but they do
affect traffic behavior. Maneuver roads export to formats such as OpenDRIVE.

By default, whenever roads cross in a junction, the RoadRunner software creates maneuver roads
automatically and makes reasonable assumptions about which roads to connect by maneuvers.
However, it is occasionally necessary to add or remove maneuvers manually. The Maneuver Tool
enables you to do so.

Maneuver roads are similar to normal roads, but they have certain restrictions. Maneuver roads are
slip roads at both ends, which means that their start and end locations and directions are constrained
to align with the anchor roads that they are attached to. For more details on slip roads, see the Slip
Road Tool.

Open the Maneuver Tool

On the RoadRunner toolbar, click the Maneuver Tool button:




Maneuver Tool

Examples

View Maneuver Roads Within Junction

1 Click the Maneuver Tool button.
2 Select a junction. This selection displays all the individual maneuvers within the junction.

Enable or Disable Automatic Maneuver Creation

By default, maneuver roads within a junction are automatically created or removed. Various
operations cause maneuver roads to be recomputed, such as moving road geometry, adding or
removing lanes, or changing lane travel directions.

Turn Automatic Maneuver Creation Off

Add a new maneuver road on page 1-58 or delete a maneuver road. These actions disable automatic
maneuver creation for the junction.

Turn Automatic Maneuver Creation On

1 Click the Maneuver Tool button.
2 Click the junction you want to examine. When a junction is selected, it displays all of the
individual maneuvers allowed within the junction.
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3 Click Rebuild Maneuver Roads to recreate all maneuver roads and re-enable automatic
maneuver creation.

Enable or Disable Automatic Maneuver Geometry

By default, maneuver road geometry is automatically updated. Various operations cause maneuver
road geometry to be updated, such as moving road geometry or changing lane widths.

Turn Automatic Maneuver Geometry On

Perform an action that modifies the geometry of the maneuver road, such as adjusting the start or
end location of a maneuver road on page 1-59 or moving a maneuver road control point on page 1-
60. The geometry of that maneuver road locks and no longer updates automatically.

Alternatively, follow these steps:

1 Click the Maneuver Tool button.

2 Click the junction you want to examine. When a junction is selected, it displays all the individual
maneuvers allowed within the junction.

3 Click the maneuver road you want to edit.

4 Select the Lock Geometry check box.

Turn Automatic Maneuver Geometry Off

1 Click the Maneuver Tool button.

2 Click the junction you want to examine. When a junction is selected, it displays all the individual
maneuvers allowed within the junction.

3 Click the maneuver road you want to edit.

4 Clear the Lock Geometry check box.

Add New Maneuver Road

1 Click the Maneuver Tool button.

2  Click the junction you want to edit. All the individual maneuvers within the junction are
displayed.

3 Click the node point where you want the maneuver to begin.

4 Right-click the node point where you want the maneuver to end. The new maneuver road is

created and visible.
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Adjust Start or End Location of Maneuver Road

1 Click the Maneuver Tool button.

2 Click the junction you want to edit. All of the individual maneuvers within the junction are
displayed.

3 Click the maneuver road you want to edit.

4  Click and drag the start or end line to adjust the shape of the maneuver road. Each line is
constrained to lie along the anchor road the line is attached to.
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Move Maneuver Road Control Point

1 Click the Maneuver Tool button.

2 Click the junction you want to edit. All the individual maneuvers within the junction are
displayed.

3 Click the maneuver road you want to edit.

4  Click and drag the desired control point to move it. Because maneuver roads are slip roads, the
first and last control points are constrained to lie along a fixed direction. For more details on slip
roads, see the Slip Road Tool.
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Insert a New Control Point Within an Existing Maneuver Road

It

If you need to define more complex trajectories through a junction, you can insert additional control
points as follows:

1 Click the Maneuver Tool button.

2 Click the junction you want to edit. All of the individual maneuvers within the junction are
displayed.

3 Click the maneuver road you want to edit.

4  Point to the blue control line at the location you want to insert a node.

5 Right-click to insert a new node within the control line of the maneuver road.
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Parameters

Attribute

Description

Turn Type

Identifies the semantic turn type for the
maneuver road (left turn, U-turn, and so on).

This type is computed automatically based on the
geometry of the junction, but there might be
some complex junctions where the type is
computed incorrectly (for example, a sharp left
turn is perceived as a U-turn).

This turn type affects the role of the maneuver in
junction signalization. See the Signal Tool.

Lock Geometry

See Enable or Disable Automatic Maneuver
Geometry on page 1-58.

See Also
Custom Junction Tool

Introduced in R2020a




Marking Curve Tool

Marking Curve Tool

Place straight or curved markings at arbitrary locations

Description

The Marking Curve Tool can be used to place straight or curved markings at arbitrary locations.

Marking curves show up on both road surfaces and terrain surfaces. They use the same linear
marking style assets as the Lane Marking Tool.

Although you can create free-form crosswalks with this tool, use the Crosswalk And Stop Line Tool

where possible, because crosswalks created in that tool have more semantic linkage to the road
topology.

Open the Marking Curve Tool

On the RoadRunner toolbar, click the Marking Curve Tool button:

Examples

Edit Marking Curves

See “Curve Editing”.

Note When creating a new marking curve, you must have Lane Marking Assets or Crosswalk
Marking Assets selected in the Library Browser.

Change the Marking on a Curve

1 Click the Marking Curve Tool button.

2 Select the marking curve you want to change.

3 Click and drag Lane Marking Assets or Crosswalk Marking Assets from the Library
Browser onto the Marking widget in the Attributes pane.

Alternatively, click and drag Lane Marking Assets or a Crosswalk Marking Assets from the
Library Browser directly onto the desired marking curve. You do not need to click the Marking
Curve Tool button first to perform this operation, because it works from any tool. Once done,
RoadRunner automatically enters the Marking Curve Tool mode and selects the changed marking
curve for further editing.
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Parameters

Attribute

Description

Marking Style

The Lane Marking Assets or Crosswalk
Marking Assets assigned.

Flip Side

If true, the order of the marking stripes is
reversed (for marking types with more than one
stripe).

Note that this value is initially computed based
on the neighboring lane travel directions when
Lane Marking Assets are assigned with the
Lane Marking Tool.

Start Blend Distance

If nonzero, the start of the marking is gradually
faded to transparent over this distance.

Note that the start is dependent on the
digitization direction of the marking curve or
road.

This option has an effect only if the material's
diffuse texture contains transparent (nonopaque)
content.

End Blend Distance

If nonzero, the end of the marking will be
gradually faded to transparent over this distance.

See the additional comments in Start Blend
Distance.

Phase Shift

This is used to offset dashed marking types along
the curve. This is useful for synchronizing the
spacing of dashes where two roads meet.

Color

Color multiplied by the material color.

Material

Material Assets to use for this marking instance.
If set, this will override the material in the Lane
Marking Assets. If not set, the marking asset's
material is used instead.

Texture Scale

Scale to apply to each dimension of the marking's
texture coordinates.

Note Note that the texture coordinate space
depends on the value of the Curve Space
Texture option in the Lane Marking Assets.

Texture Rotation

If nonzero, specifies an additional rotation to
apply to the marking's texture coordinates.

Texture Offset

If nonzero, specifies an additional offset to apply
to each dimension of the marking's texture
coordinates.




Marking Curve Tool

Attribute Description

Sort Index When markings of any type overlap, this value is
used to determine which markings appear on top.
Given two overlapping markings, the marking
with the higher sort index is drawn on top.

See Also

Introduced in R2020a
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Marking Point Tool

Place point markings (stencils), such as arrows and words, on road surfaces

Description

The Marking Point Tool enables you to place point markings (or stencils), such as arrows and
words, on road surfaces. Point markings can be added as either free-form markings, or anchored to
the center of a lane. Both Stencil Marking Assets and Texture Assets can be used as point
markings.

Open the Marking Point Tool

On the RoadRunner toolbar, click the Marking Point Tool button:

20
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Examples
Create a Road Point Marking Anchored to a Lane

Click the Marking Point Tool button.

Select one of the Stencil Marking Assets or Texture Assets in the Library Browser.
Move the pointer over the center of a lane. A lane center curve is displayed.

Right-click to add a new road point marking and anchor it to the lane.
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Alternatively, click and drag one of the Stencil Marking Assets from the Library Browser onto the
center curve of the desired lane.

Note This operation works from any tool. Once done, it automatically selects the Marking Point
Tool and selects the new point marking for further editing.

Create a Free-Form Road Point Marking

1 Click the Marking Point Tool button.

2 Select one of the Stencil Marking Assets or Texture Assets in the Library Browser.

3 Check that the point is not over the center of a lane. The lane center curve must not display.
4 Right-click to add a new free-form road point marking.

Move a Road Point Marking Anchored to a Lane

1 Click the Marking Point Tool button.



Marking Point Tool

2 Click and drag the marking you want to move to the desired location. The marking slides along
the center of the lane.

Move a Road Point Marking

1 Click the Marking Point Tool button.
2 Click and drag the marking you want to move to the desired location.

Note The marking point applies only to a road surface if it has a similar height as the road
surface.

You can use the Project Control Point button in the toolbar on the left to automatically set the
height of a point marking. You can also adjust the height manually by using the Z value in the
Attributes pane.

More About

Stencil Markings and Texture Assets

Both Stencil Marking Assets and Texture Assets can be used as point markings. The distinctions
are as follows.

Stencil Marking Assets

The marking outline is a group of polygons defined by the polygons in the SVG file. This results in
more geometry, but less overdraw when rendering. No alpha channel is required. Stencil Marking
Assets also support optional materials to fill the interior of the polygonal region.

Texture Assets

The marking outline is a rectangle. This allows any image file for Texture Assets to be used as a
point marking, but requires an alpha channel and more rendering overdraw to control the
transparent portions of the marking.

See Also

Introduced in R2020a
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Marking Polygon Tool

Define areas of asphalt patches or repeated marking stripes on roads and terrain surfaces

Description

The Marking Polygon Tool can be used to define areas of asphalt patches or repeated marking
stripes on roads and terrain surfaces. Marking polygons support the assignment of polygon marking
styles, which define the marking appearance.

Open the Marking Polygon Tool

On the RoadRunner toolbar, click the Marking Polygon Tool button:

Examples
Edit Marking Polygons

See “Polygon Editing”.

Note To create a new marking polygon, you must have one or more Polygon Marking Assets
selected in the Library Browser.

Change the Marking on a Polygon

1 Click the Marking Polygon Tool button.

2 Click the marking polygon you want to change.

3 Click and drag a polygon marking asset from the Library Browser onto the Marking widget in
the Attributes pane.

Alternatively, click and drag a polygon marking asset from the Library Browser directly onto the
desired marking polygon.

Note This operation works from any tool. Once done, RoadRunner automatically enters the
appropriate tool and selects the object for further editing.




Marking Polygon Tool

See Also

Introduced in R2020a
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Measurement Tool

Measure positions, distances, and angles in scene

Description

The Measurement Tool enables you to measure positions, distances, and angles. You can make
multiple individual measurements and place them in the scene. Measurements remain visible in other
tools, although they can be selected and modified only within the Measurement Tool. Measurements
are not permanent and are not exported with the scene.

Open the Measurement Tool

On the RoadRunner toolbar, click the Measurement Tool button:

Examples

Measure the XYZ Position at a Single Point

1 Click the Measurement Tool button.

2 If another measurement is already picked, click away from any measurements to unpick it.

3 Right-click the point you want to query. The XYZ location of the point is displayed next to it. The
location is relative to the scene origin (0,0,0). The X value is positive in the north direction. Y is
positive in the east direction. Z is positive in the up direction.

Measure the Distance Between Two Points

1 Click the Measurement Tool button.

2 If another measurement is already picked, click away from any measurements to unpick it.

3 Right-click the first point. The XYZ location of the point is displayed next to it.

4 Right-click the second point. The distance between the two points is displayed. If the two points
are at roughly the same altitude, then only the 3D distance is displayed. If the two points are at
different altitudes, then the horizontal and vertical distances are also displayed.

Measure an Angle Between Three Points

Click the Measurement Tool button.

If another measurement is already picked, click away from any measurements to unpick it.
Right-click the first point. The XYZ location of the point is displayed next to it.

Right-click the second point. The distance between the two points is displayed.

Right-click the third point. The angle between the three points is displayed.
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Measurement Tool

Measure the Distance Along Multiple Points

1
2
3
4

Click the Measurement Tool button.

If another measurement is already picked, click away from any measurements to unpick it.
Right-click to create points along the distance you want to measure.

Look at the number floating above the middle point of the measurement to see the distance the
set of points covers.

Delete a Measurement

1
2
3

Click the Measurement Tool button.
Click the measurement you want to delete.
Press the Delete key or select Edit > Delete from the menu bar.

Delete All Measurements

1 Click the Measurement Tool button.

2 If any measurements are already selected, press Ctrl+D or select Edit > Deselect All to clear
the selection set.

3  Press Ctrl+A or choose Edit > Select All to select all measurements.

4 Press the Delete key or select Edit > Delete from the menu bar.

See Also

Introduced in R2020a
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OpenDRIVE Export Preview Tool

Visualize and validate OpenDRIVE export of scene and load external OpenDRIVE files

Description

The OpenDRIVE Export Preview Tool is used to visualize and validate an OpenDRIVE export of the
current scene and to load external OpenDRIVE files. Upon entering the tool, the OpenDRIVE export
dialog box is displayed. After clicking Export, the current scene is exported to a temporary
OpenDRIVE file, which is then loaded, validated, and displayed.

Validations are run both before export and after loading the exported data. This validation output is
printed to the Output pane. Most validation errors or warnings include hyperlinks in the message.
Click a link to focus on the object or issue.

To avoid visual clutter, click the Show Background Scene button to toggle display of the scene
meshes. The Show OpenDRIVE Lane Markings button toggles display of the OpenDRIVE lane
marking attributes, which are displayed only when a road curve is selected.

You can also use the OpenDRIVE Export Preview Tool to validate and display existing OpenDRIVE
files. This can be useful for validating files from other sources or previewing an OpenDRIVE file prior
to import.

OpenDRIVE Export Preview Tool with Visual |OpenDRIVE Export Preview Tool with Visual

Scene On Scene Off

Open the OpenDRIVE Export Preview Tool

On the RoadRunner toolbar, click the OpenDRIVE Export Preview Tool button:




OpenDRIVE Export Preview Tool

Examples

Preview OpenDRIVE Data for the Current Scene

1 Click the OpenDRIVE Export Preview Tool button to open a dialog box with some OpenDRIVE
options.

2 Choose the options you want and click Export. RoadRunner exports the current scene to
OpenDRIVE and displays the resulting OpenDRIVE roads and lanes.

Load an External OpenDRIVE File for Display

See OpenDRIVE Viewer Tool.

Note This feature does not interpret any georeferencing data in the loaded file.

This feature is purely for viewing and validating an OpenDRIVE file. To import an OpenDRIVE file into
RoadRunner for editing, see “Importing OpenDRIVE Files”.

View the Attributes of OpenDRIVE Features

From within the OpenDRIVE Export Preview Tool, select lanes and other objects in the 3D edit
window to view their attributes in the Attribute pane.

Toggle the Display of 3D Scene Geometry

From within the OpenDRIVE Export Preview Tool (or any tool), select the View > Scene option in
the menu bar or press the F8 key.

Selectively Display OpenDRIVE Lanes

By default, the OpenDRIVE Export Preview Tool displays all OpenDRIVE lanes and objects in the
scene. The tool optionally provides a mode to display lanes and objects for only the selected
OpenDRIVE roads.

From within the OpenDRIVE Export Preview Tool:

1 Click the Show All Lanes button on the left toolbar.
2 The tool now displays on the OpenDRIVE road plan curves by default. When you select a road
curve, the lanes and objects for that road are displayed.

View Validation Results

From within the OpenDRIVE Export Preview Tool, examine the validation report output in the
Output pane. Most errors or warnings include a hyperlink. Click a link to focus on the object or
issue.

Search for OpenDRIVE Features
From within the OpenDRIVE Export Preview Tool:

1 Click the Search button in the sub-tool bar on the left.
2 Enter the desired search properties into the search dialog box.
3 Press the Find Next button on the search dialog box.
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This feature is useful for debugging problems if a separate application reports an issue with a specific
road ID.

See Also

Introduced in R2020a
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OpenDRIVE Viewer Tool

Visualize OpenDRIVE data for import

Description
The OpenDRIVE Viewer Tool is used to visualize OpenDRIVE data for import.

The OpenDRIVE Viewer Tool has a similar interface as the OpenDRIVE Export Preview Tool.
OpenDRIVE data brought in to the tool is visible in the scene, along with any other vector data.

Open the OpenDRIVE Viewer Tool

On the RoadRunner toolbar, click the OpenDRIVE Viewer Tool button:

Examples
Load an External OpenDRIVE File for Display

1 Click the OpenDRIVE Viewer Tool button.
2 Click and drag the desired OpenDRIVE file from the Library Browser.

View the Attributes of OpenDRIVE Features

From within the OpenDRIVE Viewer Tool, select lanes and other objects in the 3D edit window to
view their attributes in the Attributes pane.

Toggle the Display of 3D Scene Geometry

From within the OpenDRIVE Viewer Tool (or any tool), select the View > Scene option in the menu
bar or press the F8 key.

Toggle the Display of Loaded OpenDRIVE Data (Outside of OpenDRIVE Viewer Tool)

From within any tool other than the OpenDRIVE Viewer Tool, select the View > Vector option in
the menu bar or press the F7 key.

Import an OpenDRIVE File

1 Click the OpenDRIVE Viewer Tool button.
2 Click the visualized file's bounding rectangle.

Alternatively:
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* Hold the Ctrl key and click to select multiple files.

* Deselect all files to import all OpenDRIVE files.
3 Click the Convert Roads button.

4 Select desired options.
View Validation Results

From within the OpenDRIVE Viewer Tool, examine the validation report output in the Output pane.
Most errors or warnings include a hyperlink. Click a link to focus on the object or issue.

Search for OpenDRIVE Features
From within the OpenDRIVE Viewer Tool:

1 Click the Search button in the left toolbar.
2 Enter the desired search properties into the search dialog box.
3  Press the Find Next button on the search dialog box.

See Also

Introduced in R2020a
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Parking Tool

Define parking spaces and other parking-related markings

Description

The Parking Tool can be used to define parking spaces or other parking-related markings. You can
assign marking styles to the boundaries of spaces and parking nodes of parking spaces.

Parking spaces are created as a curve, where spaces are automatically created along the curve.
Parking curves are automatically created for lanes of type parking.

Parking spaces are modeled as a region graph, where each closed region represents a parking space.
Markings can be placed on the graph edge curves to represent painted boundaries.

A graph edge curve can be optionally marked as an Entry Edge. This indicates that a vehicle can
enter the parking space from that edge.

Open the Parking Tool

On the RoadRunner toolbar, click the Parking Tool button:
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Examples
Create a New Parking Curve

1 Click the Parking Tool button.

2 Check that no objects are selected. For example, you can use the Edit > Deselect All option in
the menu bar.

3 Right-click (and optionally drag) to create a curve with a single starting point. The new curve is
automatically assigned to the selected asset.

4 Right-click (and optionally drag) to extend the curve by adding additional control points.

For lanes with type parking, parking curves are automatically created and updated. For more
details, see Lane Tool.

Create a Single Parking Space

1 Click the Parking Tool button.
2 Create a parking curve with two points.
3 Check that the second point is close enough to create only one parking space.

Change the Marking on a Parking Curve

1 Click the Parking Tool button.

2 Select the parking curve you want to change.

3 Click and drag Lane Marking Assets from the Library Browser onto the Marking widget in
the Attributes pane.

Alternatively, click and drag Lane Marking Assets from the Library Browser directly onto the
desired parking space edge.

Create a Parking Lot

1 Click the Road Plan Tool button.

2 Create roads with driving lanes to define the drivable areas of the parking lot.
3 Click the Parking Tool button.

4 Create parking curves for each set of spaces.

Change the Width of Parking Spaces

1 Click the Parking Tool button.
2 Select the desired parking curve
3 In the Attributes pane, set the desired Width.

Create Angled Parking Spaces

1 Click the Parking Tool button.

2 Create a new parking curve or select an existing parking curve.
3 In the Attributes pane, set the desired Angle.

4 Assign marking styles to the desired edges.



Parking Tool

AT

Assign a Stencil Marking Style to a Parking Space

1 Click the Parking Tool button.
2 Click a parking curve.

3 Click and drag a stencil marking style onto the parking curve or assign it in the Attributes pane.

See Also

Introduced in R2020a
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Point Cloud Tool

Manage import and configuration of lidar point cloud files

Description

The Point Cloud Tool manages the import and configuration of lidar point cloud files. RoadRunner
can import a variety of point cloud file formats, such as LAS, LAZ, and PCD. Some of these formats
support georeferencing and can be automatically positioned accordingly.

Refer to the Point Cloud Assets page for a list of supported formats.

Point clouds often come from lidar scans, typically from an aerial flyover, a static terrestrial scan, or
from a moving ground vehicle.

RoadRunner can import multiple point clouds and display them all in the same 3D space, for use as
visual reference. The positioning and properties of each point cloud can be adjusted individually
using this tool.

PCD Loading

* For PCD files to load points properly, the file format must have SIZE 4 and TYPE F (float) for
coordinate FIELDS of x, y, and z. The data can be ASCII, binary, or compressed.

* For intensity, the file format must have FIELDS intensity, SIZE 4, and TYPE F.
* For color, the file format must have FIELDS rgba, SIZE 4, and TYPE U.

Open the Point Cloud Tool

On the RoadRunner toolbar, click the Point Cloud Tool button:

]
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Examples
Import a Georeferenced Point Cloud

1 Click the Point Cloud Tool button.

2 In the Library Browser, navigate to the directory containing the point cloud file you want to
import. For more details on supported point cloud files, see Point Cloud Assets.

3 Click and drag the asset from the Library Browser into the 3D scene.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the World
Settings Tool.



Point Cloud Tool

If the geographic position has already been set, but the imported image is outside of the maximum
range of the scene, an error dialog box appears and cancels the import.

Note Certain newer LAZ files are not supported in RoadRunner. As a workaround, decompress the
LAZ files into the LAS format. For instructions, see “Decompress LAZ Files”.

Remove a Point Cloud from a Scene

1 Click the Point Cloud Tool button.
2  Click within the bounding box of the point cloud you want to delete.
3 Press the Delete key or select Edit > Delete from the menu bar.

Adjust the Properties of a Point Cloud

1 Click the Point Cloud Tool button.

2 Click the point cloud you want to edit. The attributes of the point cloud appear in the Attributes
pane.

3 Adjust the point cloud attributes as desired through the Attributes pane.

Note The attributes of a point cloud are associated with the current scene, not to the point cloud file
itself. This means that any modifications to the attributes affects only the point cloud as it appears in
the current scene. These modifications do not affect if or how it appears in other scenes.

Toggle the Display of Point Clouds

Select View > Point Clouds on the menu bar or press the F6 key.

See Also

Topics
“Create Roads Around Imported GIS Assets”

Introduced in R2020a
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Prop Curve Tool

Place props and extrusions along free-form curves

Description

The Prop Curve Tool is used to place props and extrusions along free-form curves. By default, props
and extrusions are aligned with the surface terrain.

Open the Prop Curve Tool

On the RoadRunner toolbar, click the Prop Curve Tool button:

Examples

Edit Prop Curves

See “Curve Editing”.

Note When creating a new prop curve, you must have a compatible asset (Prop Model Assets,
Prop Set Assets, Extrusion Assets, and so on) selected in the Library Browser.

Change the Prop Asset on a Curve

1 Click the Prop Curve Tool button.

2 Click the prop curve you want to change.

3 Click and drag a prop asset from the Library Browser onto the Prop widget in the Attributes
pane.

Alternatively, click and drag a prop asset from the Library Browser directly onto the desired prop
curve. (Note: You do not need to select the Prop Curve Tool first to perform this operation, because
it works from any tool.) Once done, RoadRunner automatically enters the Prop Curve Tool and
selects the changed prop curve for further editing.

Convert Props Along a Prop Curve Into Individual Instances

1 Click the Prop Curve Tool button.
2  Click the prop curve you want to change.



Prop Curve Tool

3 In the Attributes pane, click Bake to turn all instances of a prop along the prop curve into
individual instances. This operation also deletes the existing prop curve and automatically enters
the Prop Point Tool.

See Also

Introduced in R2020a
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Prop Point Tool

Place individual props in scene and connect them to other props

Description

The Prop Point Tool is used for placing individual props in the scene or connecting them to other
props.

To place a prop, select the prop in the Asset Browser and right-click in the 3D scene. The prop
should appear in the scene and be positioned on whatever surface the mouse cursor is over. In this
way, props are automatically positioned on the terrain surface. If the Align Normal option is set for
the prop, it will also rotate itself to align with the surface it is placed on.

If any of the Rotation Variance or Scale Variance attributes are set for the prop, then these
properties will be randomized when the prop is placed. For example, for trees and plants, it is very
useful to set the Z-value of the Rotation Variance to 360 degrees, causing the prop to be randomly
rotated around the vertical axis and making it easier to reuse the same plant models in multiple
places without the repetition being obvious. In addition, setting the Uniform Scale Variance to 0.1
will cause a 10% randomization in the overall size of the plant.

Open the Prop Point Tool

On the RoadRunner toolbar, click the Prop Point Tool button:

Examples

Edit Prop Points
See “Point Editing”.

To create a new prop point, you must have a compatible asset (Prop Model Assets, Prop Set
Assets, and so on) selected in the Library Browser.

Add a Prop Point to the Scene

To add a prop point, follow the steps in the “Point Editing” page. Alternatively, click and drag a
compatible asset directly from the Library Browser onto the 3D scene.

Note This operation works from any tool. Once done, RoadRunner automatically enters the
appropriate tool and selects the object for further editing.




Prop Point Tool

Attach a Prop to Another Prop

Simple props can be combined and attached to one another to form more complex groups of attached
props. For example, a custom traffic signal can be constructed by combining a post, a mast, and
multiple signal heads.

1 Click the Prop Point Tool button.
2 Click and drag a compatible asset directly from the Library Browser onto the green prop
attachment curve of another prop in the scene.

For more information about prop attachment curves, see Prop Attachment Curves on page 2-19.

More About

Prop Assemblies

A group of connected props can be saved as an asset to form a prop assembly. Prop assemblies
enable you to re-instantiate a complex group of attached objects in a scene. For more details, see
Prop Assembly Assets.

See Also

Introduced in R2020a
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Prop Polygon Tool

Place props within arbitrarily shaped regions

Description
The Prop Polygon Tool allows props to be placed within arbitrarily shaped regions.

Note Prop polygons are limited to producing 10,000 individual prop instances each.

Open the Prop Polygon Tool

On the RoadRunner toolbar, click the Prop Polygon Tool button:

Examples

Edit Prop Polygons
See “Polygon Editing”.

To create a new prop polygon, you must have a compatible asset (Prop Model Assets, Prop Set
Assets, Extrusion Assets, and so on) selected in the Library Browser.

Change the Prop Asset on a Polygon

1 Click the Prop Polygon Tool button.

2 Click the prop polygon you want to change.

3 Click and drag a prop asset from the Library Browser onto the prop widget in the Attributes
pane.

Alternatively, click and drag a prop asset from the Library Browser directly onto the desired prop
polygon. (You do not need to select the Prop Polygon Tool first to perform this operation, because it
works from any tool.) Once done, RoadRunner automatically enters the Prop Polygon Tool and
selects the changed prop polygon for further editing.

Convert Props Along a Prop Polygon Into Individual Instances

1 Click the Prop Polygon Tool button.

2 Click the prop polygon you want to change.

3 Click the Bake button in the Attributes pane. This operation turns all instances of a prop within
the prop polygon into individual instances. This operation also deletes the existing prop polygon
and automatically enters the Prop Point Tool.



Prop Polygon Tool

See Also

Introduced in R2020a
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Prop Span Tool

Place props and extrusions along road

Description

The Prop Span Tool is used to place props and extrusions along a road.

Unlike the Prop Curve Tool, props placed along spans remain anchored to the road and update
automatically when the road is moved.

Open the Prop Span Tool

On the RoadRunner toolbar, click the Prop Span Tool button:

Examples
Create and Modify Prop Spans Along a Lane
See “Span Editing”.

Prop spans store prop assets (Prop Model Assets, Prop Set Assets, Extrusion Assets, and so on),
which can be directly dragged on to a lane span from the Library Browser in this tool.

Note Only a single prop asset can be assigned to a given span (although you can split a span into
two spans). To assign two prop assets (for example, a guardrail on the edge of the road and a row of
trees behind it), you can work around this limitation by assigning props to a span curve on a different
lane, and then adjusting the Offset value to shift the props.

For example, you can assign a tree asset to the inner sidewalk curve, and then increase the Offset
value to push the trees outward past the outer edge of the sidewalk.



Prop Span Tool

See Also

Introduced in R2020a
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Road Chop Tool

Chop single road into two connected roads

Description

The Road Chop Tool chops a single road into two connected roads

Open the Road Chop Tool

On the RoadRunner toolbar, click the Road Chop Tool button:

Examples

Chop a Road

1 Click the Road Chop Tool button.

2 Click the road you want to chop. Once selected, a light blue line following the pointer appears,
indicating where the chop will occur.

3 Move the pointer so that the blue line is at the location you want to chop. Then, right-click to
chop the road.

See Also

Introduced in R2020a
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Road Circle Tool

Build closed circular loop road, such as for creating roundabouts

Description

The Road Circle Tool builds a closed, circular loop based on the currently selected road style. It can
be used to build roundabouts and other circular road features. The tool builds the circle from four
connected roads, each making a single 90-degree turn.

Open the Road Circle Tool

On the RoadRunner toolbar, click the Road Circle Tool button:

~~
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Examples

Build a Circular Road

1 Click the Road Circle Tool button.

2 Optionally, click the desired road style in the Library Browser if you want to build a road of a
particular style. If no road style is picked, a basic default style is used.

3 Right-click and drag from the location of the center of the circle to the desired radius.
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See Also

Introduced in R2020a
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Road Construction Tool

Specify physical construction of road sections

Description

The Road Construction Tool enables you to specify how a section of road is physically constructed.
Currently, only standard (on terrain) and bridge types are supported. Tunnels, channels, and
abutments are not supported.

You can set the construction type for individual spans along the road. The spans are bounded by
construction nodes, which you can insert and move to arbitrary locations along the road reference
curve.

Note You cannot create intersections for bridges. Raised intersections, merges, and splits are not
supported.

Open the Road Construction Tool

On the RoadRunner toolbar, click the Road Construction Tool button:

Examples

Create and Modify Construction Types Along a Road
See “Span Editing”.
Fix Bridges Along a Road

When you create scenes that have bridges, or build scenes that have bridged roads such as by using
the Scene Builder Tool, the initially created bridge spans might not form correctly. This example
shows how to use the Road Construction Tool to fix such a bridge span in a scene.

Create two intersecting roads by using the Road Plan Tool.
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Click one of the roads to select it. In the 2D Editor pane, drag the selected road until it is 10 meters
above the other road.
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Create ground terrain around the roads by using the Surface Tool. Move the camera to view the
road intersection. The ground attaches to the elevated road, which produces visual artifacts. These
visual artifacts occur because the section of road above the other road is not designated as a bridge
span.
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To fix the visual artifacts, set the elevated road to be a bridge span. The Surface Tool ignores bridge
road spans and does not attach to these spans.

1
2
3
4

Click the Road Construction Tool button.

Click the elevated road to select it.

In the toolbar on the left, click the Auto Assign Bridges button.

In the Auto Bridge Span window, use the Bridge Span Inflation option to optionally set the
length of the bridge span. By default, the tool extends the bridge span by 20 meters on either
side of the bottom road. If the remaining road length to the left or right of the road is less the
Bridge Span Inflation value, then the bridge span extends to the end of the road. Click OK.
In the Auto Bridge Span Results window, confirm that the road was updated. Remember:

+ Ifyou selected the bottom road, then the tool processes the road but does not create a bridge
span.

» If'you previously created a bridge span for the elevated road, then the tool overrides that
original bridge span.

Close the window and view the road that has the created bridge span.



Road Construction Tool

With the Road Construction Tool still selected, if you select the middle portion of the road, the
Attributes pane shows that this portion has its Construction Span value set to Bridge. The other
two portions are set to Standard.

If you have multiple bridges to fix, then you can select multiple roads and use Auto Assign Bridges
to fix all of them at once. If you are building scenes by using RoadRunner Scene Builder, then you can
use the Auto Detect Bridges option to fix bridges. Using this option is similar to running the Auto
Assign Bridges operation on all bridges in a scene. For more details, see Scene Builder Tool.
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Parameters

Attribute Description

Construction Span * Standard — This portion of the road is at
ground level. The surrounding terrain
attaches to the sides of the span.

* Bridge — This portion of the road is elevated.
The surrounding terrain is not connected to
the sides of the span. A bridge underside
mesh is generated along the span.

When you select this option, the resulting
bridge span might be too long. To address this
issue, choose one of these options:

¢ Use the Road Chop Tool to divide the
road into sections. Then, select the section
that you want to convert into a bridge and
set Construction Span to Bridge.

o Use the Auto Assign Bridges button to
create a bridge span.

Material Material asset to be used for the sides and
underside of the bridge. See Material Assets.

See Also
Scene Builder Tool

Introduced in R2020a
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Road Superelevation Tool

Adjust superelevation (slope and banking angle) for full width of road

Description

The Road Superelevation Tool enables you to adjust the superelevation (slope and banking angle)
for the full width of a road at specified distances. To modify the slope or banking angle at specified
cross-sections of a road, use the Cross Section Tool instead.

Open the Road Superelevation Tool

On the RoadRunner toolbar, click the Road Superelevation Tool button:

Examples
Adjust Banking Angle Along Road

1 Openthe FourWayStop.rrscene scene, which is one of the prebuilt scenes that is included
with newly created RoadRunner projects. Zoom in on the scene and rotate the camera to view
the scene at an angle. All roads in this scene are flat.

2 Click the Road Superelevation Tool button.
3 Click to select one of the roads. Then, in the Attributes pane, set the Angle attribute to 10
degrees. The banking angle of the road increases by 10 degrees along the length of the road.
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4 Right-click at a point along the road to add a superelevation node. The node appears as a red bar
across the width of the road, with smaller green tangent nodes for adjusting the slope at this
node. To adjust the position of the superelevation node along the road, click and drag the red bar.

5 In the Attributes pane, decrease the Angle value of the selected node from 10 to 5. The road
now has a banking angle of 5 degrees at this node. RoadRunner interpolates the banking angle
between nodes. Because the entire road previously had a banking angle of 10 degrees, the
banking angle now gradually increases from 5 degrees at this node to 10 degrees at the road

edges.
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Parameters
Angle Superelevation angle, in degrees, specified as a

real scalar. Angle is clockwise-positive relative to
the direction in which the road was created. You
can specify the superelevation angle of the entire
road or at superelevation nodes along the road.

Distance Position of superelevation node along the road, in
meters, specified as a nonnegative real scalar.
Distance is relative to the edge of the road that
was created first.

Slope Slope of superelevation node tangent, in degrees
per meter, specified as a real scalar.

See Also
Cross Section Tool

Introduced in R2021a
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Road Height Tool

Manipulate vertical profile of roads

Description

The Road Height Tool allows the manipulation of the vertical profile of roads.

The height profile is defined relative to the distance along the road and is constructed of straight line
sections and quadratic (parabolic) blend sections. The height profile can also be converted to a
sequence of cubics with tangents on nodes.

For tips on dealing with height alignment in intersections, see “Resolve Triangulation Issues in
Junctions”.

Open the Road Height Tool

On the RoadRunner toolbar, click the Road Height Tool button:

Examples

Insert a New Height Node

Click the Road Height Tool button.

Click to select a road.

Right-click the road curve at which you want to insert a height node.

Optionally, you can hold the right-click button and drag the height node to the desired height.

A WNR

Alternatively, insert a height node from the 2D Editor pane.
1 Click the Road Height Tool or Road Plan Tool button.



Road Height Tool

2 C(lick to select a road.
3 In the 2D Editor pane, right-click the road curve where you want to insert a height node.

Adjust the Height of a Node

1 Click the Road Height Tool button.

2 Click to select a road.

3 Click and drag the node you want to edit to the desired height.

4 Optionally, click the node and type the desired height into the Attributes pane.

Alternatively:

1 Click the Road Height Tool or Road Plan Tool button.
2 C(lick to select a road.
3 Inthe 2D Editor pane, click and drag the node along the vertical axis.

Move a Height Node Along the Road

1 Click the Road Height Tool button.

2 Click to select a road.

3 Click to select a node.

4 Adjust the Distance value in the Attributes pane.

Alternatively:

1 Click the Road Height Tool or Road Plan Tool button.
2 (lick to select a road.
3 Inthe 2D Editor pane, click and drag the node along the horizontal axis.

Delete a Road Height Node

1 Click the Road Height Tool button.

2  Click to select a road.

3 Click to select a node.

4 Press the Delete key or select Edit > Delete from the menu bar.

Adjust the Height of a Section Between Nodes

1 Click the Road Height Tool button.

2  Click to select a road.

3 Click and drag the curve section you want to edit to the desired height.

4 Optionally, click the curve section and type the desired height into the Attributes pane. This
value sets the height of the nodes at the start and end of the curve section.

Alternatively:

1 Click the Road Height Tool or Road Plan Tool button.
2 Click to select a road.
3 In the 2D Editor pane, click and drag the curve section along the vertical axis.

Adjust the Size of a Quadratic Blend Section
1 Click the Road Height Tool button.
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Click to select a road.

Click the height node in the middle of the blend section you want to edit. Two green dots appear
at the limits of the blend region.

4 Click and drag either of the green dots to adjust the range of the blend region.

5 Optionally, you can type the desired blend range into the Attributes pane. This value sets the
height of the nodes at the start and end of the curve section.

WN

Convert the Profile to Cubic Interpolation

1 Click the Road Height Tool button.
2 Click to select a road.
3 Click Use Cubic Interpolation.

30

Use Cubic Interpolation

Convert the Profile to Quadratic Interpolation

1 Click the Road Height Tool button.
2 Click to select a road.
3 Click Use Quadratic Interpolation.

Adjust the Tangent of a Height Node

1 Click the Road Height Tool button.

2 Click to select a road.

3 Click the height node.

4 Click and drag either of the green dots to adjust the slope.

Disconnect the Tangents of a Height Node

1 Click the Road Height Tool button.
2  Click to select a road.

3  Click the height node.

4 Click Disconnect Tangents.

_.,\\_.. 10
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Disconnect Tangents

Connect the Tangents of a Height Node
1 Click the Road Height Tool button.
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2 Click to select a road.
3 Click the height node.
4 Click Connect Tangents.

Y, Connect Tangents

Project Roads to Elevation Maps

RoadRunner can project one or more roads down to the height of an elevation map (see Elevation
Map Assets). This process samples the elevation data under the road and performs a constrained fit
of the road elevation to the trace of the elevation data beneath the road.

Before Height Projection After Height Projection

The blue trace shows the height of the elevation |The road height (red trace) now aligns with the
map underneath the road. elevation map (blue trace) underneath the road.

1 Click the Road Plan Tool button.

2  Select the roads you want to project. (You can perform a Select All operation to select all roads
in the scene).

3 Click the Project Roads button on the toolbar on the left.

There are two types of height projection that can be performed: a relaxed fit and a tight fit. The type
of fit used depends on whether the road uses quadratic or cubic interpolations.

Relaxed Fit

If a road is using quadratic interpolation on page 1-104, a relaxed, approximate fit is used. This
interpolation is best when the terrain data is either noisy or low resolution.
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Tight Fit

If a road is using cubic interpolation on page 1-104, a much tighter fitting method is used. This
interpolation is best when you want the road to closely match the heights of the elevation map.

See Also

Introduced in R2020a
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Road Offset Tool

Adjust connection between two end-to-end roads

Description

The Road Offset Tool is used to adjust the connection between two end-to-end roads. Roads can be
shifted laterally to align the lanes of each road.

Note Slip roads cannot be offset using this tool. Slip roads will automatically align to the side of the
road from which they originate.

Open the Road Offset Tool

On the RoadRunner toolbar, click the Road Offset Tool button:

Examples

Offset a Road

1 Click the Road Offset Tool button.
2 Click the desired road. The road must be connected to another road at its other end.
3 Click and drag the arrows at the desired end of the road.

Note Holding the Ctrl key disables lane snapping.

See Also

Introduced in R2020a
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Road Plan Tool

Create and lay out roads

Description

The Road Plan Tool is the primary tool for creating and laying out roads. It allows for creation and
manipulation of the 2D reference curve that the road layout is based on. The height of the road can
be manipulated independently using the Road Height Tool. Intersections are created automatically
where roads overlap.

Roads automatically participate in the terrain surface graph. For more information about this
interaction, refer to the “How Surfaces Work in RoadRunner”.

Open the Road Plan Tool

On the RoadRunner toolbar, click the Road Plan Tool button:

Examples

Create a New Road

1 Click the Road Plan Tool button.

2 If another road is already selected, click away from any road to unselect it.

3 Optionally, click the desired road style in the Assets Browser to build a road of a particular
style. If no road style is picked, a basic default style will be used. For more information about
road styles, see Road Style Assets.

4 Right-click at the location you want to start a new road.

5 Right-click additional times to create additional road control points to extend and shape the road.

Move Road Control Point

1 Click the Road Plan Tool button.
2 Click the road you want to edit. The road is highlighted, and the control points are displayed and
connected by light blue lines.



Road Plan Tool

3 Click and drag the desired control point to move it.

4 Optionally, you can click to select the point, and then type a precise position in the Attributes
pane.

Note The end control points and the first interior control points have some special properties when
roads are connected end-to-end:

Moving the end control point of one of the roads will move the end of the connected road and

update the first interior control point of the other road to ensure that the road directions remain
aligned at this end, as shown here:
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* Moving the first interior control point of one of the roads will move the first interior control point
of the other road (by rotating it about the end point) to ensure that the road directions remain
aligned at this end, as shown here:

Insert New Control Point Within Existing Road

1 Click the Road Plan Tool button.

2 Click the road you want to edit.

3 Move the mouse cursor over the blue control line at the location you want to insert a node.
4 Right-click to insert a new node within the control line of the road.

Radies: iR
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Adjust Radius of Road Curve

By default, the circular arcs in the road curves will fit in the space available. If a smaller curve radius

is desired:

1 Click the Road Plan Tool button.

2 Click the road you want to edit. The road is highlighted, and the control points are displayed and
connected by light blue lines.

3 Click the control point closest to the circular arc you want to modify. The attributes of the
selected control point will appear in the Attributes pane.

4 Adjust the Max Radius value to the desired radius. If you do not see anything change, then try a

lower value, because Max Radius will limit the maximum radius of the arc.

Adjust Curvature of Road Curve

See “Explicit Road Curves” on page 1-117.

Extend Existing Road

You can extend an existing road in either direction by adding more control points, as follows:

1
2

3

Click the Road Plan Tool button.

Click the road you want to extend. The road is highlighted, and the control points are displayed
and connected by light blue lines.

Click the control point on the end of the road you want to extend.

Right-click to create a new control point and extend the road.
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Note For optimal performance, avoid very long individual roads. Keeping individual roads under 500
m is recommended. To create stretches of road longer than 500 m, use multiple roads connected end-
to-end. Refer to “Create New Road Connected End-to-End With Another Road” on page 1-112 and
“Connect Two Roads End-to-End” on page 1-113.

Create New Road Connected End-to-End With Another Road

In a similar fashion to extending an existing road, you can also create a new road that connects end-
to-end with an existing road. The visual result is similar to extending the existing road, but there are
some important situations where end-to-end roads are needed:

* To avoid extremely long roads for performance reasons
» To create a road loop or self-intersecting road

You can create an end-to-end road that connects with an existing road as follows:

1 Click the Road Plan Tool button.

2 If another road is already selected, click away from any road to unselect it.

3 Click the lavender road node line at the end of a road.

4 Right-click to create a new control point, which creates a new road that extends off the existing
one.



Road Plan Tool

Connect Two Roads End-to-End

Similar to the steps above, you can extend a road and simultaneously connect it to the end of an
existing road as follows:

1 Click the Road Plan Tool.
2 Click the road you want to extend. The road is highlighted, and the control points are displayed
and connected by light blue lines.

3 Click the control point on the end of the road you want to extend.
4 Right-click the lavender line at the end of another road.

Create Road Loop

You can create a closed loop road by combining the steps above or by using the Road Circle Tool.

Note Closed loops require at least three separate roads. You cannot form a loop from a single road.

1 Create the first road by using the “Create a New Road” on page 1-108 steps.
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2 Create the second road by using the “Create New Road Connected End-to-End With Another
Road” on page 1-112 steps.

3 Create the final road by using the “Create New Road Connected End-to-End With Another Road”
on page 1-112 steps, followed by the “Connect Two Roads End-to-End” on page 1-113 steps to
end the road.

Delete Road Control Point

1 Click the Road Plan Tool button.

2 Click the road you want to delete the point from. The road is highlighted, and the control points
are displayed and connected by light blue lines.

3  Click the control point you want to delete.

4 Press the Delete key, or select Edit > Delete from the menu bar.
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Delete Road

1 Click the Road Plan Tool button.
2 Click the road you want to delete.
3  Press the Delete key, or select Edit > Delete from the menu bar.

Create Intersection

At-grade intersections are created automatically in RoadRunner wherever two or more roads cross.

Four-Way Intersections

To create a four-way intersection, create two roads that fully overlap:

T-Junctions

To create a T-junction, create two roads where one ends within the extents of the other:
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Ramps and Splits

To create onramps, offramps, and road splits, refer to the Slip Road Tool documentation.

Self-Intersections

A single road should not overlap itself. If you need to create a road that loops back on itself, either
chop the road with the Road Chop Tool, or create roads connected end-to-end:

Roads may not cross themselves

Instead, create two or more roads connected end-
to-end

Double-Crossings

You might observe issues with lane markings when two roads cross each other twice (that is, two at-
grade intersections are formed between the same two roads).

Avoid double-crossing roads. If you need to create a double-crossing situation, either chop one of the
roads with the Road Chop Tool, or initially create one of the roads using two end-to-end roads.




Road Plan Tool

Avoid roads that cross each other twice. Instead, split one of the roads in two

(Note the lavender bar indicating an end-to-end
connection.)

Note Intersections are only created when the roads have similar heights at the crossing locations. To
adjust road heights, use the Road Height Tool.

Explicit Road Curves

By default, new roads will be created out of straight lines and circular arcs. Roads created in this
method are called "Automatic." It is sometimes desirable to instead define a road curve as an explicit
set of straight lines, circular arcs, clothoids (spirals), and parametric cubics (Hermite curves).

Roads created in this method are called "Explicit." Each line, arc, spiral, or cubic is called a
"Segment." The Explicit Road Curve also allows you to set the tangents of the road at each control
point. Editing the control points of an explicit curve is done the same as with an automatic curve.
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Building Roads With Explicit Curves

Explicit curves can be used to create a road with a very specific profile (for example, a 50 m linear
section, followed by a 20 m spiral with specific starting and ending curvatures, followed by a 30 m
arc with specific curvature, and so on).

To build such a road, follow these steps:

1 Click the Road Plan Tool button.

2 Create a new road using these steps: “Create a New Road” on page 1-108.

3 Convert the new road to explicit form using these steps: “Make Road Curve Explicit” on page 1-
118.

4 Adjust the type and properties of the first road section.

5 For each new section you want to add to the road:

1 Add a new section using these steps: “Extend Existing Road” on page 1-111.
2 Adjust the type and properties of the new road section.
Make Road Curve Explicit

1 Click the Road Plan Tool button.
2 Click the road you want to change.
3 In the Attributes pane, press Convert to Explicit.

Make Road Curve Automatic

1 Click the Road Plan Tool button.
2  Click the road you want to change.
3 In the Attributes pane, press Convert to Automatic.

Note Converting an explicit curve to an automatic curve can slightly change the curve and insert
additional points.




Road Plan Tool

Change Tangent of Explicit Curve

1 Click the Road Plan Tool button.
2  Click the road you want to change.
3 Click and drag one of the tangent control points and move it to set the desired tangent.

Note Setting tangents on a road may change the type of the segments connected to the affected
control point.

Change Type of Segment

1 Click the Road Plan Tool button.

2 Click the road you want to change.

3 Click the segment you want to change.

4 In the Attributes pane, select the Type of the segment. This will automatically constrain the
segment's points and tangents to match the type.

Change Length of Segment

1 Click the Road Plan Tool button.

2  Click the road you want to change.

3 Click the segment you want to change.

4 In the Attributes pane, adjust the Length of the segment to the desired length.

Note You can set the length of a segment only if the segment is a line, arc, or spiral.
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Change Curvature of Segment

1 Click the Road Plan Tool button.

2  Click the road you want to change.

3 Click the segment you want to change.

4 In the Attributes pane, adjust the Curvature (for circular arcs) or Start Curvature/End
Curvature (for spirals).

Note You can set the curvature of a segment only if the segment is an arc or spiral.

See Also

Introduced in R2020a
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Road Speed Limits Tool

Set speed limits along road spans

Description

The Road Speed Limits Tool enables you to set varying speed limits along sections of a road. When
you export your scene to a simulator, you can use these values to test whether vehicles drive the set

speed limits.

Open the Road Speed Limits Tool

On the RoadRunner toolbar, click the Road Speed Limits Tool button:

SPEED
LIMIT

25

Examples
Set Speed Limits Along Road
This example shows how to set varying speed limits along a simple curved road.

Create a curved road segment by using the Road Plan Tool.
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Divide the road into sections along which to set different speed limits.

1 Select the Road Speed Limits Tool button.

2 Select the road by clicking it.

3 Right-click the road at two locations to divide it into three sections. To adjust the sections, click
and drag the dividing nodes along the curve of the road.
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ﬁ§

By default, each section of the road has a speed limit of 40 miles per hour. Set the middle section of

the road to a lower speed limit.

1 Click the middle section of the road to select it.




1 Tools

2 In the Attributes pane on the right, set the Speed Limit to 20.

You can then adjust the sections further or add or delete sections. To delete a section, click a dividing
node to select it, and then click Delete. When you delete a dividing node, the merged section inherits
the speed limit of the road section that had the higher speed limit.

Parameters

Attribute Description

Speed Limit Speed limit of road section, specified as a
nonnegative integer.
By default, units are in miles per hour. To change
units to kilometers per hour, in the menu bar,
select Tools > Scene Settings. Then, set Speed
Units to KPH.
Default: 40

Road Type Type of road, specified as Unknown, Rural,
Motorway, Town, Low Speed, Pedestrian, or
Bicycle.
Default: Town

See Also

Road Plan Tool

Introduced in R2020b
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Scene Builder Tool

Generate 3D scenes from HERE HD Live Map data

Description

To import, inspect, and build scenes from HERE HD Live Map data, use the Scene Builder Tool.
After building the scene, you can edit and export the scene by using other RoadRunner capabilities.

HERE HD Live Map, developed by HERE Technologies, is a cloud-based web service that enables you
to access highly accurate, continuously updated map data. The data is composed of tiled map layers
containing information such as the topology and geometry of roads and lanes and scene objects such
as signs, poles, and barriers.

The Scene Builder Tool is part of RoadRunner Scene Builder, an add-on product that requires an
addition to your RoadRunner license. For more details, see “Get RoadRunner Updates and
Upgrades”. You also need to enter into a separate agreement with HERE Technologies to gain access
to HERE HD Live Map data and to get the required Marketplace credentials (Access Key ID and
Access Key Secret).

Open the Scene Builder Tool

On the RoadRunner toolbar, click the Scene Builder Tool button:

N>

Examples
View HERE HD Live Map Scene Data for Visual Reference

View HERE HD Live Map data in RoadRunner for an area in Santa Clara, California. You can use this
data as a visual reference to manually create roads on or around it.

Choose Area of Interest

Specify an area of interest by using the World Settings Tool.
v

For this example, specify the world origin latitude as 37 .4156 degrees and the world origin longitude
as -121.9749 degrees. Specify the X and Y workspace extents as 750 meters. Apply your changes by
clicking Apply World Changes.
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Import and Explore Data

Open the Scene Builder Tool from the toolbar. Then, import the data by clicking the Import Data
for Area button from the toolbar on the left.

Before you import the data, enter the credentials that you obtained from HERE Technologies. Enter a
valid Access Key ID and Access Key Secret, then click OK. The credentials are saved for the rest of
your RoadRunner session on your machine. To save your credentials for future RoadRunner sessions
on your machine, in the dialog box, select Save my credentials. The credentials remain saved until
you delete them.

The Scene Builder Tool imports HERE HD Live Map data from HERE tiles that intersect your
workspace, converts the data into a preview called a Transfer Map, and displays the Transfer Map
in the scene editing canvas. The Transfer Map displays scene objects as blue points and colors
according to the confidence classification of the road data. For more information about classification,
contact HERE Technologies.

Explore the imported data by selecting control points, lane boundaries, lanes, and lane groups. You
can view information such as classification, ID, and lane length from the Attributes pane.

You can manually create on or around this data. Alternatively, if you have a RoadRunner Scene
Builder license, click Build Scene to builds roads directly from the data.


https://www.here.com/

Scene Builder Tool

Tips

You can view the Transfer Map while using a different tool by selecting View > Transfer Map from
the menu bar. Transfer Maps do not persist between RoadRunner sessions.

See Also
World Settings Tool

Topics
“Build Scenes by Using HERE HD Live Map Data”
“Configure Assets to Use for Imported HERE HD Live Map Data”

Introduced in R2020b

1-127



1 Tools

Scene Export Preview Tool

Preview scene geometry to be exported

Description

The Scene Export Tool can be used to visualize the exact scene geometry that will be exported. You
can also use it to query properties, such as triangle and material counts. Tile counts are determined
by fitting the Tile Size and Center parameters to the Scene Extents.

Open the Scene Export Preview Tool

On the RoadRunner toolbar, click the Scene Export Preview Tool button:

Examples

Adjust the Export Tile Size

1 Select the Export to Tiles toggle.

2 Adjust the Tile Size parameters to modify the size of individual tiles.
3 Adjust the Center parameters to modify the overall tiling center.

4 Click Preview Export.

Preview Segmentation Output

1 Modify the Split by Segmentation toggle.
2 Press Preview Export.
3 Enable segmentation display to preview segmentation categories in this tool.

See Also

Topics
“Customize Levels of Detail in Exported Scenes”

Introduced in R2020a
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Screenshot Tool

Generate and save image of current camera view

Description

The Screenshot Tool generates and saves an image of the current camera view. The dimensions of
the screenshot can be set independently of the dimensions of the actual viewport. This allows for full
control over the resolution and aspect ratio of the image without being limited to the resolution of the
monitor. The Screenshot Tool also allows control over the camera field of view.

Open the Screenshot Tool

On the RoadRunner toolbar, click the Screenshot Tool button:

Examples

Generate a Screenshot

1 Click the Screenshot Tool button.

2 Adjust the resolution and field of view as desired through the Attributes pane.
3 Click the Take Screenshot button on the Attributes pane.

4 Specify the file name and location in the File Save dialog box and click Save.

Generate a Quick Screenshot

1 Open any tool with the desired camera position. Quick screenshots use the current viewport
settings and resolution.

2 Either select Tools > Quick Screenshot from the menu bar or press Ctrl+P.

3 Specify the file name and location in the file save dialog box and click Save.

See Also

Introduced in R2020a
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Sidewalk Height Tool

Modify sidewalk and curb heights

Description

The Sidewalk Height Tool enables you to modify the heights of sidewalks and curb heights along a
road. You can modify these heights along the entire length of a road or at arbitrary points along a
road.

Open the Sidewalk Height Tool

On the RoadRunner toolbar, click the Sidewalk Height Tool button:

k)

Examples

Modify Height of Sidewalk

1 Create a straight road segment by using the Road Plan Tool. Zoom in on one side of the road
and rotate the camera so that part of the sidewalk is clearly in view.

2 Click the Sidewalk Height Tool button. The sidewalk lane becomes selectable, as indicated by a
purple line above the sidewalk.
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3 Click the sidewalk lane to select it. Then, in the Attributes pane, set the Offset attribute to 0.5
meters. The height of the sidewalk increases along the entire road edge.

lediesd
4 Double-click along the selected sidewalk lane to add three evenly spaced sidewalk height nodes.
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5 Select the outer nodes and, in the Attributes pane, set the Offset to 0.1 meters. The sidewalk
now has a slope at the center node, which still has a height of 0.5 meters.

6 Drag the center node between the outer nodes. The sidewalk height changes as you drag the
center node. You cannot drag a sidewalk height node past other height nodes or past the start or
end of a lane.



Sidewalk Height Tool

See Also
Cross Section Tool

Introduced in R2021a
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Signal Tool

Configure junction signalization and signal traffic phases

Description

The Signal Tool is used to configure junction signalization and signal traffic phases.

A junction's signalization can be static (not changing, for example, controlled by stop signs) or
dynamic (controlled by dynamic traffic signals). The signalization of a junction is defined using
phases. A phase indicates which signals are active and the state of the maneuver roads (for example,
whether traffic may enter the junction along a given maneuver road — for more details, see
Maneuver Tool).

Each phase is composed of several intervals. An interval is a period in a junction that corresponds to
allowed movements. Typically, there are three intervals in a phase: green, yellow, and red.

The Signal Tool provides several autosignalization operations for automatically applying
signalization templates to a junction. These operations can also automatically place Prop Assembly
Assets and Signal Assets.

Signal assets are linked to junctions by associating them to maneuver roads. This association can be
performed manually, but an automatic detection operation can attempt to identify nearby signals and
compute associations. A single signal asset can be associated with maneuver roads in multiple
separate junctions.

Open the Signal Tool

On the RoadRunner toolbar, click the Signal Tool button:
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Examples

Autosignalize a Junction

RoadRunner provides an autosignalization feature that can be used to apply common signalization
templates to an intersection. For example, use these steps to quickly configure a four-way stop, a
signalized intersection with protected left turns, and so on:

1 Click the Signal Tool button.
2 Select a junction.
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3 In the Attributes pane, click Auto Signalize.

Junction Signalization

Auto Signalize

4 From the Auto Signalize Junction window, select a signalization template. Then, click Signalize.

1-136



Signal Tool

Auto Signalize Junction >

Choose a signalization

Signalizations

All Go

All Stop

All Yield

Split Phase

4 Way Protected Left

4 Way Permitted Left

Automatically Place Selected Prop

Signalize Cancel

Tip If a prop or assembly is selected in the Library Browser first, select Automatically Place
Selected Prop to automatically place the prop and connect any signals to the junction.

Add an Empty Phase

1 Click the Signal Tool button.
2 Select a junction.
3 Right-click beyond the end of the phases in the 2D Editor pane.

Alternatively, right-click an existing phase to duplicate it.

Tl

Clear All Phases
1 Click the Signal Tool button.
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2 Select a junction.
3 Press the Delete key or select Edit > Delete from the menu bar.

Specify a Maneuver Road's State in a Phase
To control the traffic state of a maneuver road in a given signal phase, follow these steps:

1 Click the Signal Tool button.

2 Select a junction.

3 Select the desired phase in the 2D Editor pane.

4 Select the maneuver road whose state you want to change.

5 Choose a State in the Attributes pane.

Maneuver Signalization

State
o Aly o

Yield

Stop

Stop/field

Specify a Signal State in a Phase

To control a traffic signal's bulb states in each interval of a given signal phase, follow these steps:
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Click the Signal Tool button.

Select a junction.

Select a gate. Gates appear as lavender bars on maneuver roads.

Select a signal you want to disassociate.

Choose a signal state for each interval in the States group of the Attributes pane.

A WNH

Signal

Signal Variant | yariant 1 (RedYellowGreen)

States

Green Interval | config 3 (Green)
Yellow Interval | config 2 (Yellow)

RedInterval | config 1 (Red)

Note If no States group appears, then the selected signal is not associated with any maneuver road
gates in this junction. Refer to the Associate a Signal with a Maneuver Road Gate on page 1-141
section.

Edit a Phase Duration
To change the duration of each interval in a signal phase, follow these steps:

1 Click the Signal Tool button.

2 Select a junction.

3 Select the desired phase in the 2D Editor pane.

4 Change the Interval Time in the Attributes pane.
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Phase Mame
Interval 1

Interval Mame

Interval Type

Interval Time 20.000

Interval 2

Interval Mame

Interval Type | vellow

Interval Time 4,000
Interval 3

Interval Mame

Interval Type

Interval Time 1.000

Change the Current Phase

1 Click the Signal Tool button.
2 Select a junction.
3 Select the desired phase in the 2D Editor pane.

Alternatively, click the phase arrow buttons in the 2D Editor pane.

2D Editor | Signal Phases

Tip You can scrub through the signal phases by dragging the timeline bar in the 2D Editor pane:
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Associate a Signal with a Maneuver Road Gate

To manually associate a maneuver road with one or more Signal Assets, follow these steps.

Note In many cases, the Auto Detect Signals operation (see next section) works sufficiently. Try
that operation first.

1 Click the Signal Tool button.
2 Select a junction.
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3 Select a gate. Gates appear as lavender bars on a maneuver road.

Note Multiple gates might overlap. Cycle-select to choose which gate to edit. For more details,
see “Cycle-Select Overlapping Objects”.
4 Right-click the signal you want to associate the maneuver with.

Note You cannot associate to signals in Prop Assembly Assets. You must first expand the
assembly. See Expand a Prop Assembly on page 2-17.

Alternatively:

Click the Signal Tool button.

Select a junction.

Select a gate. Gates appear as lavender bars on a maneuver road.
Select a signal.

Click Add to gate in the Attributes pane.

a A W N R

Signal

Signal Variant | yariant 1 (RedYellowGreen)

Add to gate
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Automatically Associate Signals with Maneuver Road Gates

This operation locates signals surrounding an intersection and attempts to automatically associate
signals with maneuver road gates.

1 Click the Signal Tool button.

2 Select a junction.

3 Click the Auto Detect Signals button in the Attributes pane. At least one phase must be
present in the junction.

Junction Signalization

Auto Signalize

Auto Detect Signals

This operation uses the maneuver road turn types when determining which signals to associate with.
If a maneuver road is being associated to an inappropriate signal, verify that the maneuver road's
turn type is correct using the Maneuver Tool.

Note Automatic detection does not work for signals in Prop Assembly Assets. You must first
expand the assembly. See Expand a Prop Assembly on page 2-17.

Remove a Signal Association from a Maneuver Road Gate

Click the Signal Tool button.

Select a junction.

Select a gate. Gates appear as lavender bars on a maneuver road.
Select a signal you want to disassociate.

Click Remove from gate in the Attributes pane.

UL WNRH

Gates

Right Turn

Straight

Tips

+ If the signals do not automatically detect the correct states, choose the phase, click the signal, and
set the desired states. Properly setting the Supported Turn Types for the signal can result in
better automatic choices.

» Before autosignalizing to automatically place signals, create a traffic light assembly and select it
in the Library Browser.

1-143



1 Tools

See Also

Introduced in R2020a
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Sign Tool

Modify custom signs, such as street name signs and freeway billboards

Description

Use the Sign Tool to modify custom signs, such as street name signs and freeway billboards. You can
partition the sign into rectangular regions and then place text, graphics, and colored rectangles
within the sign.

RoadRunner Demo

Sign Creation w
- .f

On the RoadRunner toolbar, click the Sign Tool button:

Open the Sign Tool

Examples
Place Instance of Sign in Scene

To place a sign in a scene, click and drag the sign asset from the Library Browser into the scene.
Alternatively, follow these steps:

1 Click the Sign Tool button.
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2 Click the desired sign asset.
3 Right-click in the scene to place the sign.

Modify Sign Regions

You can create separate regions within a sign and modify each region separately.

Split a Region into Two Regions

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

3 Click the region you want to split.

4 Click the Add Horizontal Split or Add Horizontal Split button.

N =

When you click the button, the region splits at the middle and draws a separator line. To adjust
the position of the split, you can click and drag the separator itself to the appropriate position.

Delete a Region

1 Click the Sign Tool button.

2 Click the sign you want to edit.

3 Click the region to delete.

4 Press Delete to remove the region.

Edit the Color and Boundary Properties of a Region

Click the Sign Tool button.

Click the sign you want to edit.

Click the region you want to edit.

Set the Color and Boundary properties in the Attributes pane.

AWNR

Modify Sign Text

You can add text boxes to signs and edit the text within them.
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You can also modify the visual properties of the text and modify the fonts. RoadRunner uses the
standard system fonts installed through the operating system. For details on adding new fonts, see
“Text Fonts” on page 1-149.

Add New Text Box

1
2

3

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the Add Text button to create a new editable text box in the sign.

The text box inherits the properties of the last picked text box and appears centered in the last
picked region.

Delete Text Box

1
2

3
4

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the text box you want to delete.

Press the Delete key, or select Edit > Delete from the menu bar.

Edit Text in Text Box

1
2
3
4

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the text box you want to edit.

Select the Text attribute on the Attributes pane, and type in the desired string.

Change Font or Other Visual Properties of Text Box

1
2
3
4

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the text box you want to edit. The attributes of the text box appear in the Attributes pane.
Edit the desired attributes on the Attributes pane. The Small Caps option can be used to format
lowercase letters as smaller capital letters

Modify Sign Graphics

You can add bitmap or vector graphic to signs and modify the shape, color, or visual properties of
these graphics.
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Add New Sign Graphic

1
2

3

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click and drag a graphic onto the sign.

Delete Sign Graphic

1
2

3
4

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the graphic you want to delete.

Press the Delete key or select Edit > Delete from the menu bar.

Edit Shape of Graphic

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the graphic you want to edit.

Click and drag the edges of the graphic. The pointer changes to the resize symbol.

Change Color or Other Visual Properties of Graphic

1
2

3
4

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the graphic you want to edit. The attributes of the graphic appear in the Attributes pane.
Edit the desired attributes in the Attributes pane.

Modify Sign Rectangles

You can add rectangles to within signs and modify the shape, color, and other visual properties of the
rectangle.

Add New Sign Rectangle

1
2

3

Click the Sign Tool button.

Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

Click the Add Rectangle button on the toolbar on the left.

7 \|

+

The new rectangle inherits the attributes of the last rectangle selected or has default values if no
rectangle has been selected.

[N




Sign Tool

Delete Sign Rectangle

1 Click the Sign Tool button.

2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

3 Click the rectangle you want to delete.

4 Press the Delete key or select Edit > Delete from the menu bar.

Edit Shape of Rectangle

1 Click the Sign Tool button.

2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

3  Click the rectangle you want to edit.

4 Click and drag the edges of the rectangle. The pointer changes to the resize symbol.

Change Color or Other Visual Properties of Rectangle

1 Click the Sign Tool button.

2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in
the 3D scene.

3 Click the rectangle you want to edit. The attributes of the rectangle appear in the Attributes
pane.

4 Edit the desired attributes in the Attributes pane.

More About

Text Fonts

RoadRunner uses the standard system fonts installed through the operating system. You can specify
the font for each text box individually. Fonts for street signs in different countries are available from
various sources online. For example, Roadgeek 2005 is a good resource of sign fonts.

In the United States, most freeway and street signs are based on a set of fonts known as Highway
Gothic, formerly known as the FHWA Series fonts. These fonts were originally published in 1948 as
the FHWA's Standard Alphabets for Traffic-Control Devices and have been updated several times. The
original series had variants ranging from Series A (narrow) to Series F (wide). Series A is no longer
used in the U.S. because it was too narrow. Series E has a wider variant known as Series E-Modified
or sometimes Series E(M), which is used on many freeway guide signs. Highway Gothic is used in
several other countries as well.

Several U.S. states have adopted a newer font called Clearview, which was developed to improve
readability over the Highway Gothic font. There are different sets of Clearview fonts for light letters
on dark backgrounds, and dark letters on light backgrounds. There are six sizes in each set that vary

from narrow to wide. This leads to at least 12 variations on the font, usually labeled 1B-6B, and
1W-6W, plus a 13th revised version of 5W called 5WR.

See Also

Introduced in R2020a
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Slip Road Tool

Create onramps, offramps, and road splits

Description

The Slip Road Tool is used to create onramps, offramps, and road splits.

When using the Slip Road Tool, a light blue circle follows the pointer. This circle snaps to lanes and
the lavender road node lines at the ends of roads.

Different actions occur depending on which objects you select, the locations where you right-click,
and whether you are pressing the Shift key.

Open the Slip Road Tool

On the RoadRunner toolbar, click the Slip Road Toel button:

1-150



Slip Road Tool

Examples

Create a Single-Lane Onramp or Offramp

1 Click the Slip Road Tool button.

2 Move the pointer over the outermost driving lane of a road. The light blue circle gets slightly
larger.

3 Right-click and drag to show a preview of the slip road to create. This action forms either an
onramp or offramp, depending on whether you are dragging ahead of the starting point or behind
the starting point.

4 Release the right-click button to create the road.

Tip If you release the right-click button on another road, the new road is a slip road at both ends.
For example, it could be an offramp for the first road and an onramp for the second.

Junctions are automatically created whenever multiple roads overlap, including in slip road cases.
Refer to “Junctions and Traffic Signals” for more information on working with junctions.

For example, you can use the Corner Tool to adjust the geometry of the curve between the ramp and
the main road:

Junctions involving slip roads still contain maneuver roads (see Maneuver Tool). The automatically-
created maneuver roads are not guaranteed to match the expected connectivity. It is recommended to
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double-check maneuver road topology in slip road junctions as you would do with an at-grade
intersection. This is important to ensure that the lane connectivity is correct when exporting to a
format like OpenDRIVE.

Create a Multilane Onramp / Offramp

Click the Slip Road Tool button.

Move the pointer over the innermost driving lane that you want to connect to the ramp. The light
blue circle gets slightly larger. This lane and all lanes up to the edge of the road will connect to
the ramp.

Right-click and drag to show a preview of the slip road to create. This action forms either an
onramp or offramp, depending on whether you drag ahead of the starting point or behind the
starting point.

Release the right-click button to create the road.
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Slip Road Tool

Note By default, the driving lanes between the selected lane and the edge of the road end at the
new junction. That is, in an offramp case, these lanes are dedicated offramp lanes that do not
continue along the main road. If you hold the Shift key when you release the right-click button, this
behavior is disabled and all driving lanes continue along the main road.

Create a Road Split

You can split a road into two roads by creating slip roads at the end of a road.

1 Click the Slip Road Tool button.

2 On the lavender road node line at the end of a road, move the pointer over the innermost driving
lane that you want to connect to the new slip road. The new slip road will include this lane and
all lanes up to the edge of the road.

3 Right-click and drag to show a preview of the slip road.

4 Release the right-click button to create the road.

You can optionally provide more fine-grained control over the lanes to be included in the slip road.
This is useful for creating more advanced types of road splits.

Before following the steps above, select a range of lanes on the lavender road node line. The created
slip road will connect to the range of lanes defined by the innermost and outermost selected lanes.
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Create a Channelized Turn Lane

You can also use the Slip Road Tool to create physically separated, branching lanes in any situation.

For example, you can create a channelized right turn lane on an at-grade intersection. Follow the
steps to create a single lane on page 1-151 or multilane on page 1-152 ramp on a road leading up to
an intersection. If you end your drag on the crossing road, it will create a channelized turn lane.

Adjust Where a Slip Road Is Connected

You can adjust where a slip road is attached to the road at its ends:

1 Select the Road Plan Tool.
2 Click and drag the dashed lavender road node at the end of a slip road.

See Also

Introduced in R2020a
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Surface Tool

Model surfaces around roads, such as walkways, driveways, parking lots, and natural terrain

Description

The Surface Tool models surfaces around roads, such as walkways, driveways, parking lots, and
natural terrain. For more details on surfaces, see “How Surfaces Work in RoadRunner”.

Open the Surface Tool

On the RoadRunner toolbar, click the Surface Tool button:

Examples

Edit Terrain Surface Curves and Regions

See “Region Graph Editing”.

Insert a Terrain Surface Node Along a Road Boundary

1 Click the Surface Tool button.
2 Right-click a terrain surface curve along a road boundary.

Note You can slide these types of nodes along the road using click and drag.

Change the Material Assigned to a Terrain Surface

1 Click the Surface Tool button.
2 Select a terrain surface.
3 Assign one of the Material Assets to the Material widget in the Attributes pane.

Alternatively, click and drag one of the Material Assets from the Library Browser onto a terrain
surface. This operation can be performed in any tool.

Control Whether a Surface Uses Elevation Samples

By default, the interior of a surface is smoothly interpolated from its boundaries. Surfaces can
optionally use the elevation maps in the scene to determine the heights of interior points as follows:

1 Configure the elevation maps through the Elevation Map Tool as desired, using the previous
instructions.
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2 Click the Surface Tool button.
3 Select a surface.
4 Enable the Sample Global Elevation option in the Attributes pane.

Note This setting affects only the interior of the surface. The heights along the perimeter of the
surface are still defined by the surface curves, which are independent from the elevation map.

You can better align the perimeter of a surface to the elevation map by first inserting additional nodes
along the perimeter of the surface (where needed). Then, project the nodes to the surface using the
Project Nodes button in the toolbar on the left.

Parameters

Material The Material Assets to apply to the surface.

Offset An XY offset to apply to the texture coordinates of
the surface.

Scale An XY scale to apply to the texture coordinates of
the surface.

Rotation An additional rotation to apply to the texture
coordinates of the surface.
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Attribute Description

Height If nonzero, the surface is extruded upward by this
amount.

Flat Top If a terrain surface's curves are not flat, then this

option forces the extruded top of the surface to
be flat.

This attribute affects only surfaces with nonzero
Height values.

Extrude Inner Regions

If true, any enclosed surfaces form either holes or
raised areas (depending on the elevation of their
surface curves). If false, the outer surface slopes
downwards (or upwards) to meet the height of
the enclosed surface.

Only impacts surfaces with nonzero Height
values.

See Also
“How Surfaces Work in RoadRunner”

Introduced in R2020a
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Vector Data Tool

Manage import and configuration of vector data files and explore shape attributes

Description

The Vector Data Tool manages the import and configuration of vector data files, and enables
exploration of the shape attributes. RoadRunner can load a variety of georeferenced vector map files,
such as Shape files (. shp), OpenStreetMap® files (.osm), GeoJSON files (. json, .geojson), and
GPS Exchange files (. gpx). Vector data such as points, lines, and polygons can be loaded from these
files along with their associated attributes.

Refer to the Vector Data Assets page for a list of supported formats.

Note The Vector Data Tool is used to visualize and explore vector file types for use as visual
references. Automatic conversion of vector map data into the RoadRunner internal format is not
supported.

Open the Vector Data Tool

On the RoadRunner toolbar, click the Vector Data Tool button:

Q o
v/

Examples

Import a Georeferenced Vector Map

1 Click the Vector Data Tool button.

2 In the Library Browser, navigate to the directory containing the vector data asset you want to
import. For more details, see Vector Data Assets.

3 Click and drag the asset from the Library Browser into the 3D scene.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the World
Settings Tool.

If the geographic position has already been set, but the imported image is outside of the maximum
range of the scene, an error dialog box appears and cancels the import.

Remove a Vector Map

1 Click the Vector Data Tool button.



Vector Data Tool

2 Click within the bounding box of the vector map you want to delete. Do not click the vector
element itself. Instead, click an empty space within the bounding box. When the map is clicked,
the bounding box turns red.

3 Press the Delete key or select Edit > Delete from the menu bar.

Adjust the Properties of a Vector Map

1 Click the Vector Data Tool button.

2 Click within the bounding box of the vector map you want to adjust. Do not click the vector
element itself. Instead, click an empty space within the bounding box. When the map is clicked,
the bounding box turns red.

3 Adjust any properties as desired on the Attributes pane.

Toggle the Display of Vector Data
Select View > Vector Data on the menu bar or press the F7 key.
View the Attributes of a Feature in a Vector Map

1 Click the Vector Data Tool button.
2 Click the vector feature you want to examine. The properties of the feature are displayed in the
Attributes pane.

* You can select multiple features to view the aggregate set of attributes for all selected
features.

* Ifyou click an attribute field name or value in the Attributes pane, the main scene highlights
the objects with that value.

Color Features Based on Attributes

3l Fra@pEeo s
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You can apply custom colors to vector features based on type or other attribute values as follows:

1 Click the Vector Data Tool button.

2 Select the features that you want to recolor (or press Ctrl+A to select all).

3 In the Attributes pane, locate the feature attribute that you want to use for recoloring. If you
click an attribute field name or value, the main scene highlights the objects with that value.

4 Right-click an attribute field name or value, and select Color With.

5 Choose a color in the color picker.
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Note You can hide the highlighted features by setting the Alpha channel value to 0.

Clear Feature Colors

If you assigned a custom color to vector features, you can clear the custom color as follows:

1 Click the Vector Data Tool button.

2 Select the features whose colors you want to reset (or press Ctrl+A to select all).

3 In the Attributes pane, locate the feature attribute whose colors you want to reset.
4 Right-click an attribute field name or value and select Clear Colors.

See Also

Introduced in R2020a
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World Settings Tool

Configure geographic position and size of environment model for data import and export

Description

The World Settings Tool is used to configure the geographic position and size of the environment
model.

RoadRunner allows models to optionally be georeferenced, meaning they are built to match a
particular location on the surface of the Earth.

For more information about the coordinate system used in RoadRunner, refer to “Coordinate Space
and Georeferencing”.

Open the World Settings Tool

On the RoadRunner toolbar, click the World Settings Tool button:

Examples

Specify an Initial Latitude/Longitude Origin for the Scene

1 Click the World Settings Tool button.

2 Enter the desired latitude and longitude that you want to use as the origin of the scene in the
World Origin section of the Attributes pane.

3 Click the Apply World Changes button on the Attributes pane.

Clear the Geographic Position

1 Click the World Settings Tool button.

2 Press the Clear World Projection button in the Attributes pane.

3 A warning dialog appears, saying that clearing the projection invalidates imported GIS files. To
proceed, press the Clear button.

Center the Geographic Position on an Existing GIS File

Click the World Settings Tool button.

Click the GIS file you want to center the projection on.

Press the Center World on Selected button in the Attributes pane.

Press the Apply World Changes button in the Attributes pane.

A dialog box appears, asking if you want to just change the world projection (the Only Change
Projection button) or if you want to transform the model to the new projection (the Transform

A WNH
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Scene button). See the note on changing world settings to determine the appropriate action and
click the appropriate button.

Change the Origin of the Environment to a Specific Latitude/Longitude

Click the World Settings Tool button.

Enter the desired latitude and longitude that you want to use as the origin of the scene in the
World Origin section of the Attributes pane.

Click the Apply World Changes button on the Attributes pane.

A dialog appears, asking if you want to just change the world projection (the Only Change
Projection button) or if you want to transform the model to the new projection (the Transform
Scene button). See the note on changing world settings to determine the appropriate action and
press the appropriate button.

Alternatively, follow these steps:

1

Click the World Settings Tool button. Locate the green circular mark indicating the World
Origin.

Click and drag the World Origin mark to the desired new origin position.

Click the Apply World Changes button on the Attributes pane.

A dialog appears, asking if you want to just change the world projection (the Only Change
Projection button) or if you want to transform the model to the new projection (the Transform
Scene button). See the note on changing world settings to determine the appropriate action and
press the appropriate button.

Note To transform a scene, you have two options:

Only Change Projection — Use this option if you want to change the origin without moving any
scene objects. This changes the lat/long locations of the ohjects but preserves their local (XY)
coordinates.

Transform Scene — Use this option if you want to change the origin and move objects to
preserve their location on the earth. This changes the local (XY) coordinates of the objects but
preserves their geographic (lat/long) coordinates.

Change the Workspace Size and Location

1 Click the World Settings Tool button.
2 Enter the desired workspace parameters (Center and Extents) on the Attributes pane.

Alternatively, follow these steps:

1

Click and drag inside the blue World Origin box in the scene editing canvas to move the center
of the workspace.

Click and drag the edges or corners of the blue World Origin box to change the dimensions of
the workspace.

Click the Apply World Changes button on the Attributes pane.



World Settings Tool

Note Changing the workspace does not remove or modify any data in the scene. When working with
large GIS files, it can be useful to shrink the workspace to view only the portion of the file you want to
view at a given time. However, remember to increase the workspace size again before exporting.

More About
Working with GIS Data

Before importing any GIS files or before starting to model any roads, set the desired latitude and
longitude in your scene. See “Specify an Initial Latitude/Longitude Origin for the Scene” on page 1-
161. This enables you to enter explicit latitude and longitude values.

Another option is to center the origin on the first GIS file imported. RoadRunner does this
automatically if you try to drag a GIS file into the scene without having set the origin. Once the origin
is set, any additional GIS files brought in are positioned relative to the specified origin.

Note that you can always adjust your world origin later, though it is recommended to make all
adjustments prior to creating any roads or other scene elements. Changing the world origin after GIS
files have been imported will change the map projection and will require all GIS files to be reloaded
and reprojected. This is done automatically when you change the origin.

Scene Workspace

The scene workspace defines the rectangular size of the environment model. This rectangular region
is referred to as the workspace and is based on a center XY coordinate (in meters relative to the
origin) and an XY rectangle size, defined in meters.

Because GIS data can get quite large, RoadRunner loads only GIS data that lies within the
workspace. The scene workspace is also used for export. The visual scene is geometrically clipped
against the scene workspace during export.

To change the workspace dimensions, see “Change the Workspace Size and Location” on page 1-162.

See Also

Topics
“Create Roads Around Imported GIS Assets”

Introduced in R2020a
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Aerial Image Assets

Add GIS satellite and aerial imagery to scene for visual reference

Description

Aerial image assets are used to add geographic information system (GIS) satellite and aerial imagery
to a scene, typically for visual reference.

Refer to the Aerial Imagery Tool for instructions on adding and adjusting aerial images in your
scene.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

Image file types that RoadRunner supports:

* Bitmap (. bmp)

* DEM (.dem) — Typically used only for Aerial Image Assets or Elevation Map Assets
* GIF (.gif)

+ GTX (.gtx)

e ICO (.ico)

+ IMG (.img)

* JPEG 2000 (.jp2)

* JPEG (.]jpg, -jpeg)

« PPM/PGM /PBM (.ppm, .pgm, .pbm)
* PNG (.png)

* RGB (.rgb, .rgba)

* SVG(.svg, .svQgz)

* TGA(.tga)

* TIF / GeoTIFF (.tif, .tiff)
 WEBP (.webp)

* X Bitmap Graphic (.xbm)



Aerial Image Assets

* X PixMap (.xpm)

GeoTiff, JPEG 2000, and IMG are most common image file types for georeferenced imagery.
See Also

Topics
“Create Roads Around Imported GIS Assets”
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Crosswalk Marking Assets

Define crosswalk marking properties, such as color, width, and spacing

Description

Crosswalk marking assets describe the general properties of a crosswalk marking, such as color,
width, spacing, and so on. These assets are used by features such as the Crosswalk And Stop Line

Tool and the Marking Curve Tool.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

Parameters

Attribute Description

Width Width between the centers of the left and right
stripes.

Border Width Width of the left/right stripes.

Dash Length Length of each dash in ladder-style crosswalks.
If zero, no dash will be present.

Dash Gap Length between dashes in ladder-style
crosswalks.

Default Material Material Assets used by crosswalk instances.
This material will be used by any crosswalk
instances that do not have an overriding material
(that is, crosswalks that do not have an assigned
Material attribute in the Marking Curve Tool
attributes.)

Changing this value will impact any existing
crosswalk instances (except those that have an
overriding material assigned).

Category “Segmentation” type for this marking asset.

See Also




Elevation Map Assets

Elevation Map Assets

Add GIS raster elevation data to scene

Description

Elevation Map Assets are used to add geographic information system (GIS) raster elevation data to a

scene.

Refer to the Elevation Map Tool for instructions on adding and adjusting elevation maps in your
scene.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag

the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

e DEM (.dem)
 IMG (.1img)
o TIF / GeoTIFF (.tif, .tiff)

See Also

Topics
“Create Roads Around Imported GIS Assets”
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Extrusion Assets

Define extruded geometry for features such as walls, guard rails, and fences

Description

Extrusion assets are used to create extruded geometry for features such as walls, guard rails, and

fences.

Extrusions can combine an extruded cross section (such as the metal railing of a guard rail) with
regularly spaced props (such as the wooden posts of the guard rail). These extrusions can be placed
along curves using the Prop Curve Tool, and along road spans using the Prop Span Tool.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

Parameters

Attribute

Description

Default Spacing

Controls how often a prop is placed along the
extrusion.

Instance Offset

An offset (in the space of the curve) applied to all
props placed along the extrusion.

Item 0, Item 1, and so on

Regularly repeated props within an extrusion.
See Add a Repeating Prop to an Extrusion.

You can add a constant offset to all props placed along the extrusion by adjusting the Instance

Offset attribute in the Attributes pane.

Examples




Extrusion Assets

Edit the Shape of an Extrusion

2D Editor | Extrusion

1.1

1.0

Select an extrusion style in the Library Browser to view the extrusion profile in the 2D Editor
pane.
2 See “Curve Editing”.

The editing controls for extrusions differ from most curve-based tools. For example, there is no
explicit tangent control or tangent locking/unlocking. To create a sharp angle, you would create
two curves and drag the endpoints of one until it snaps to the end of the other.

Assign Materials to an Extrusion

1 Select an extrusion style in the Library Browser to view the extrusion profile in the 2D Editor
pane.

2 Select an extrusion curve in the 2D Editor pane.

3 Modify any of the following attributes in the Attributes pane.

Attribute Description

Material Material asset to apply to the selected
extrusion curve. For more details, see
Material Assets.

Texture Size Texture coordinate scale for the selected
extrusion curve.
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Attribute Description
Two Sided Whether the material applies to both sides of
the selected extrusion curve or a single side.
Two-sided is typically only used for thin
fences (for example, chain link fences).
More About

Add a Repeating Prop to an Extrusion

You can add regularly spaced props along an extrusion. This is useful to add posts and other supports

along the extrusion.

Note that extrusion assets behave much like Prop Set Assets. Refer to that documentation for
instructions on adding and removing prop items on an extrusion asset.

See Also




Lane Marking Assets

Lane Marking Assets

Define lane markings, such as color, width, and dash spacing

Description

Lane marking assets describe the properties of lane markings, such as color, width, dash spacing, and
so on. These assets are used by features such as the Lane Marking Tool, Marking Curve Tool, and
the Marking Polygon Tool. Making a change to a lane marking style will affect all instances that use
that style.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

Parameters

Attribute Description

Marking Type Line marking pattern.
"Solid" is a continuous unbroken line, while
"Dashed" refers to a broken line with separate
controls for gap and dash lengths.

Width Width of each marking stripe.

Separation Gap between marking stripes (for marking types
with more than one stripe).

Dash Length Length of marking dashes (for "Dashed" marking
types).

Dash Spacing Length of gaps between dashes (for "Dashed"
marking types).
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Attribute

Description

Curve Space Texture

If true, the marking material will be applied in
the space of the curve. The vertical axis of the
texture will be mapped along the curve, and the
horizontal axis will span the total width of the
marking.

If false, then the marking material will be applied
in 'world space', where the vertical axis of the
texture will be mapped based on the global 'Y
axis, and the horizontal axis will be mapped
based on the global 'X' axis.

Default Color

Initial color to assign to marking instances. Refer
to the "Color" attribute in the Marking Curve
Tool attributes.

Modifying this value in the asset does not impact
any existing marking instance.

Default Material

Material Assets used by lane markings in the
scene. This material will be used by any marking
instances that do not have an overriding material
(that is, markings that do not have an assigned
Material attribute in the Marking Curve Tool
attributes.)

Changing this value will impact any existing
marking instances (except those that have an
overriding material assigned).

Default Start Blend Distance

Initial Start Blend Distance to use for marking
instances. Refer to the Start Blend Distance
attribute in the Marking Curve Tool attributes.

Modifying this value in the asset does not impact
any existing marking instance.

Default End Blend Distance

Initial End Blend Distance to use for marking
instances. Refer to the End Blend Distance
attribute in the Marking Curve Tool attributes.

Modifying this value in the asset does not impact
any existing marking instance.

Category

“Segmentation” type for this marking asset.

See Also
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Material Assets

Define visual properties of surfaces, sidewalks, lanes, and other objects

Description

Material assets are used to define the visual properties of surfaces, sidewalks, lanes, and other
objects.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

See Also
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Point Cloud Assets

Add aerial or vehicular point clouds to scene for visual reference

Description

Point cloud assets are used to add aerial or vehicular point clouds to a scene, typically for visual
reference.

Refer to the Point Cloud Tool for instructions on adding and adjusting point clouds in your scene.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

o LAS/LAZ (.las, .laz)
* PCD(.pcd)

Note LAZ files version 1.4 or higher might not load correctly. In these cases, you might need to
decompress the files to LAS files. For more details, see “Decompress LAZ Files”.

See Also
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Polygon Marking Assets

Define space-filling road markings, such as crosshatch and chevron markings

Description

Polygon marking assets describe the properties of space-filling road markings, such as crosshatch
and chevron markings.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

See Also
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Post Assets

Define building support posts, such as for bridges and overpasses

Description

Post assets are used for building support posts of varying height, primarily for bridges and
Overpasses.

You cannot change the material, customize the extrusion profile, or add caps to post assets.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

See Also
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Prop Assembly Assets

Define collection of prop instances stored as single asset

Description

i
Rl
=

=t =]
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Prop assembly assets are hierarchical collections of prop instances stored as a single asset that can

itself be instantiated within the scene.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,

editing, and deleting assets, see “Create, Import, and Modify Assets”.

Examples

Create a Prop Assembly

1 Select the Prop Point Tool.
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2 Select the root node of a hierarchical prop (a point prop with one or more props attached to it).
3 Click the Create Assembly button in the Attributes pane.

A new assembly asset appears in the current folder of the Library Browser and can be renamed.

The selected prop node is automatically replaced by this new assembly.

Attach a Prop to a Prop Assembly

1 Select the Prop Point Tool.

2 From the Library Browser, drag a prop onto the prop assembly. Alternatively, select a prop from
the Library Browser, and then in the scene, right-click the green attachment curve of an
assembly at the point where you want to place the prop.

You can then drag the prop anywhere within the assembly, but you cannot move it off the
assembly. You also cannot drag props already in the scene onto an assembly. You must attach new
props directly from the Library Browser.
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Expand a Prop Assembly

1 After placing a prop assembly instance in the scene, you can expand it to separate it into its
individual components, which breaks the instance's link to the prop assembly asset).

This is useful when you want to modify only a single instance of the assembly. For example, if you
want to move a traffic signal head on a traffic assembly.

Select the Prop Point Tool.
2 Select a prop point with a prop assembly assigned to it.
3 Click the Expand Assembly button.

See Also
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Prop Model Assets

Define external 3D model files to add to scene

Description

Prop model assets reference external 3D model files that can be placed within the scene.

Refer to “Props and Signs” for details on adding prop model assets to the scene.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

* glTF™ (.gltf, .glb)

* Filmbox (. fbx)

* OpenFlight (. f1t)

* OpenSceneGraph (.0sg, .0sgt, .osgb, .ive)
*  Wavefront (.obj)
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Parameters

Attributes
Prop Model (Eucalyptus_Sm0 1. fox)
Placement

Rotation Variance

Uniform Scale Variance | 0,100
Align Mormal

Default Spacing 5,000

Segmentation

Category Prop

Import Settings

Front Axis | v+ Front

All prop assets have a set of options that affect the way the props are placed. For example, some
props will always align vertically, such as a traffic signal. Other props will align to the surface they
are placed on, such as a garbage can sitting on a sloped sidewalk. (This option can be toggled on a
prop-by-prop basis.) Other options include the ability to randomly rotate the prop around the vertical
axis, which is useful for varying the orientation of trees and plants.

To set the default attributes for a particular prop asset, first select the prop in the Asset Browser. The
prop's attributes will then appear in the Attributes pane, where they can be interactively adjusted.

More About

Prop Attachment Curves

An attachment curve is a spline associated with a prop that RoadRunner uses as a cue when
attaching objects to each other.
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As an example, note the green highlight line in the following signal pole prop. The image on the right
is a close-up that shows this detail.

When you pick another prop from the Library Browser and bring it sufficiently close to the
attachment curve, they snap together at that point. In this case, a signal mast arm has been attached.
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Creating Prop Attachment Curves

RoadRunner does not have a user interface for creating prop attachment curves directly. However, if
you have access to a third-party tool like Maya® or Blender®, you can create these yourself on any
prop. Add a spline named attachment into the object hierarchy.
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If the attachment curve is not appearing in RoadRunner, you may need to add more curve points so
that it can be detected. In Maya, this option is under Curve > Rebuild.
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Edit Help

Rebuild type: ® Uniform
Mo multiple knots Curvature

End conditions

Parameter range: ® {to1 LEED 0 to #5pans

Keep: v Ends angents CWs NumSpans
Mumber of spans: 2

Degree 1 Linear s ® 3 Cubic

Keep original

Rebuild Apply

Format Details
FBX Details

.

Layered Textures are not supported and will not be connected to the imported materials.
Texture transformations (scale, rotation, and translation) are not supported and will be ignored.
RoadRunner supports importing FBX® Lambertian and Phong materials.

Multiple UV sets are not supported. These extra UVs must be removed in a program like Maya
before being imported into RoadRunner.

Importing lights from FBX files is not supported.

Levels of Detail (LODs) are based on the node name. During import, RoadRunner checks if the
node name ends with _med, low, or verylow.

Note RoadRunner does not render lower LODs, so nodes that end in _med, low, or verylow
will not be visible.

gITF Details

Texture sampler settings are not imported and defaults to repeat on both axes.
Sparse accessors are not supported.
Point and line primitive modes are not supported.

OpenSceneGraph Details

When importing materials, 0sg: : Textures are loaded as materials. These single texture
materials will take precedence over 0sg: :Materials when generating the mesh.
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* Only Overall and Per Vertex color bindings are supported.
* Multiple UVs are not supported. Only the first texture coordinate array is used.
* Point and line PrimitiveSet modes are not supported.

Advanced Details

Textures

Most 3D models have associated image files (such as texture maps or normal maps). Place these
image files in the same directory as the prop model itself, or (in certain formats, such as FBX) they
can also be embedded into the actual prop file.

Unit Scale and Coordinate System

* RoadRunner uses meter units. Imported FBX files will automatically convert units if needed.

* RoadRunner uses the Maya Z-up coordinate system: +Z is up, +X is right, and -Y is toward the
camera.

Note Imported FBX files will automatically rotate to match the coordinate system. However, FBX
files created in a left-handed coordinate system will not be converted properly.

See Also
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Prop Set Assets

Define collections of props that have a random distribution

Description

Prop set assets reference collections of different props that have a random distribution. For example,
you can create a prop set of trees that contains a collection of different tree models. Prop sets specify
a relative distribution for each item in the set. This influences the likelihood of that item appearing
when the prop set is added to the scene. Prop sets can be placed on points, curves, polygons, and
spans.

Creation

Create these assets from within the RoadRunner Library Browser. For more details on creating,
editing, and deleting assets, see “Create, Import, and Modify Assets”.

If you have one or more prop assets selected when you create the new prop set, those assets are

automatically added to the new prop set. If no prop assets are selected, an empty prop set is created.

Examples

Add an Item to a Prop Set

1 Select a prop set in the Library Browser.

2 Click the Add Prop button in the Attributes pane. A new (empty) item is added to the end of the
list of items.

3 Assign a prop style asset to the prop by dragging an asset from the Library Browser into the
empty Prop asset picker box.

You can use any of the following asset types as a prop set item:

* Prop Assembly Assets
* Prop Model Assets
* Prop Set Assets

Remove an Iltem from a Prop Set

1 Select a prop set in the Library Browser.
2 Click the Remove Prop button below the item you want to remove in the Attributes pane.
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See Also

2-26



Road Style Assets

Road Style Assets

Define templates that specify properties of new roads

Description

Road style assets are templates that specify the properties used when creating new roads. These
properties include the number of lanes, lane types, lane widths, lane marking materials, and road
cross section information. It also contains information about extrusions, such as barriers and
repeated props.

Road style assets are typically used only when initially creating a road. After that point, you can use
the road tools described in “Roads, Lanes, and Markings” to customize any aspect of the created
road.

A selection of road styles is included with RoadRunner. You can create new road styles and modify
existing ones.

Road style creation and editing differs from many other asset types. Refer to the steps listed here.

Creation

You can create a style from any road in your RoadRunner scene.

1 Find or create a road and customize it to your liking using the road tools. For more details, see
“Roads, Lanes, and Markings”.

Select the Cross Section Tool.

Select the road.

Right-click a location along the road to create a cross section (or click an existing cross section).

a A W N

Click the Make Road Style button on the Attributes pane to create a road style in the current
Library Browser folder.

6 Rename the road style asset, if desired.
Examples

Apply Road Style to New Road

Refer to the Road Plan Tool documentation.
Apply Road Style to Existing Road

Click and drag the road style from the Library Browser onto the road you want to change.
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This operation changes the entire road and overwrites any local changes previously made to the road,
such as lane edits, marking edits, attribute edits, cross section edits, and more. Therefore, it is
recommended that you use it only when first creating a road.

Edit Road Style Asset

You can replace the contents of a road style asset with a new road style. This action does not affect
any previously created roads.

1 Find or create a road and customize it to your liking using the road tools. See “Roads, Lanes, and
Markings”.

2 Select the Cross Section Tool.

3 Select the road.

4 Right-click a location along the road to create a cross section (or click an existing cross section).
5 Click the Update Selected Style button in the Attributes pane.

See Also
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Signal Assets

Define dynamic traffic signal heads with lights

Description

Signal assets are 3D models that allow for dynamic traffic signal heads with lights.

In many regards, signal assets are similar to Prop Model Assets. For example, the same steps are
used to add signal assets to the 3D scene.

The “RoadRunner Asset Library Add-On” includes a variety of signals. You can also add your own
custom signal models (refer to the Create a Custom Signal Prop section below).

Signal assets include the notion of variants, which allow the same 3D model to be configured with
multiple different bulb layouts. For example, a single 3-bulb model could have one variant for
green/red/yellow ball lights, and another for green/red/yellow left turn lights. Variants require two
texture atlases that define the on and off state for all bulbs available for that signal. For details on
creating texture atlases, see Texture Assets.

Each variant defines a set of supported turn types that are used to automatically map signals to
maneuvers with the Signal Tool.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

« Filmbox (. fbx)
*  Wavefront ( . ObJ )

Examples

Create a Signal Variant

1 Select a signal asset in the Library Browser.
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2 Click Add Variant in the Attributes pane.

Add Variant

Set Bulb Textures

1 Select a signal asset in the Library Browser.
2 Assign texture atlases to the On Texture and Off Texture asset pickers in the Attributes pane.

On Texture .

1 Signals_LightsOn01_Diff.png

Signals_LightsOff01_Diff.png

Name or Rename a Signal Variant

1 Select a signal asset in the Library Browser.
2 Choose the variant to edit in the Variant drop-down list in the Attributes pane.
3 Set the Name of the variant in the Attributes pane.

Variant Variant 1 (RedyelowGreen)

Mame RedyelowGreen

On Texture .

Set or Change a Bulb Type

1 Select a signal asset in the Library Browser.
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2D Editor | Signal Asset

2 Select a bulb in the 2D Editor pane.
3 Choose a bulb type (Variant Bulb Type) in the Attributes pane.

Signal Bulb

Variant Bulb Type

Specify Supported Turn Types

1 Select a signal asset in the Library Browser.
2 Choose the variant to edit in the Variant drop-down list in the Attributes pane.
3 Check the boxes that correspond to the controlled turn types for this signal.
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Supported Turn Types
Straight u

|
Right
UTurnLeft
TurnRight

Custom

Remove a Signal Variant

1 Select a signal asset in the Library Browser.
2 Choose the variant to remove in the Variant drop-down list in the Attributes pane.
3 Click Remove Variant.

Remove Variant

Create a Signal State

1 Select a signal asset in the Library Browser.
2 Click Add State in the Attributes pane.

Name or Rename a Signal State

1 Select a signal asset in the Library Browser.

2 Choose the variant to edit in the Variant drop-down list in the Attributes pane.
3 Choose the state to edit in the State drop-down list.

4 Set the Name of the state in the Attributes pane.

State | State 3 (Go)

Mame Go
State Turn Types

Straight | green

Specify State Supported Turn Types

1 Select a signal asset in the Library Browser.



Signal Assets

Choose the variant to edit in the Variant drop-down list in the Attributes pane.

Choose the state to edit in the State drop-down list.

Set the signal mode for each supported turn type in the State Turn Types group.
Mame

State Turn Types

EtI'EIIght areen

Left Permitted

Right Green

Remove a Signal State

1
2
3
4

Select a signal asset in the Library Browser.

Choose the variant to edit in the Variant drop-down list in the Attributes pane.
Choose the state to edit in the State drop-down list.

Click Remove State.

Remove State

Create a Custom Signal Prop

NounhphWNR

Model the signal in a 3D modeling program.

Create bulb meshes for each bulb.

Prefix the name of each bulb mesh with light

Construct the UVs of the bulb mesh using the full UV grid size (0 to 1).
Export as FBX.

Add the asset file using the Library Browser.

Right-click the asset and set the Default Type to Signal.
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Signal_21 i+
_Bare Mew

Rename

Default Type Prop Model

Signal_:
_Pos Show In Explorer Signal

-I Update Assets

Tips

* If automatic detection in the Signal Tool does not choose the correct state for a signal, try
adjusting the supported turn types for the state or variant.
* Make a red state first, because this will be the default.

« If the signal bulbs do not display correctly, ensure that the on and off textures are set and that
both of those textures are texture atlases with the correct grid size. For more details on texture
atlases, see Texture Assets.

See Also
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Sign Assets

Define standard and custom street signs

Description

Sign Assets are used to create and edit standard and custom street signs.

Creation

RoadRunner has tools for quickly creating both basic and complex road signs. These signs can be
created and stored in the project assets, and then placed throughout the scene in 3D. A basic sign is a
sign that is built from a single image file (bitmap or vector graphic), such as a stop or yield sign. A
complex sign can have multiple elements, such as text and graphics, such as a custom freeway guide
sign. Both basic and complex signs can be created as assets in the asset library and then instanced in
the scene as props.

Create Basic Sign Asset from Single Bitmap or Vector Image

1 Click in the Asset Browser to select the destination directory in which to import the sign.

2 Drag the bitmap file (JPG, PNG, or BMP) or vector graphic file (SVG) from a file browser into the
Asset Browser. This action copies the actual file into the project assets. Once the image is in the
project assets, RoadRunner automatically generates an icon for the image.

3 Right-click the asset icon and select the Default Type > Sign menu option. This treats the image
file as a sign asset type and is necessary because images can be used as other asset types as
well.

Create Complex Sign Asset with Custom Text and Graphics
To create a complex sign asset with custom text, graphics, and so on, follow these steps:

1 Click in the Asset Browser to select the destination directory in which to import the sign.
2 Right-click in the Asset Browser and select the New > Sign menu option. This selection creates
a new sign asset that can be further customized with the Sign Tool.

Supported Formats
Image file types that RoadRunner supports:

* Bitmap (.bmp)

* DEM (.dem) — Typically used only for Aerial Image Assets or Elevation Map Assets
* GIF (.gif)

« GTX (.gtx)
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*+ ICO(.ico)

 IMG (.img)

* JPEG 2000 (.jp2)

« JPEG(.jpg, .jpeg)

« PPM/PGM /PBM (.ppm, .pgm, .pbm)
* PNG (.png)

* RGB (. rgb, .rgba)
* SVG(.svg, .svQgz)
* TGA(.tga)

» TIF / GeoTIFF (.tif, .tiff)
* WEBP (.webp)

* X Bitmap Graphic (.xbm)

* X PixMap (.xpm)

Examples

Permanently Delete Sign Asset from Project

1 Click the sign asset you want to delete in the Asset Browser.

2 Press the Delete key, or select Edit > Delete from the menu bar.

3 A dialog box warns you that this operation permanently deletes the file. Click Yes if you want to
proceed.

Modify Existing Sign Asset

1 Click the sign asset you want to edit in the Asset Browser to display the attributes of the sign in
the Attributes pane.

2 Edit the sign attributes.

3 Inthe menu bar, select File > Save Project. Changes to assets are not saved until you save the
project.

See Also
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Stencil Marking Assets

Define road paint features, such as arrows, text, and symbols

Description

N

\

Stencil marking assets are used to place road paint features, such as arrows, text, and symbols.

Refer to the Marking Point Tool for more information about using stencil marking assets as point
markings.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

* SVG(.svg, .svQgz)

Examples

Create a Stencil Marking Asset

1 Add the asset file using the Library Browser.
2 Right-click the asset and set the Default Type to Stencil Marking.

The SVG parser used for stencil markings is limited. Many SVG elements are not supported. If
your SVG is not supported and you want to use the stencil as a point marking, you can convert it
to any of the supported non-SVG image file types and use the Marking Point Tool to add the
resulting texture assets to the scene. For a list of supported non-SVG image file types, see
Texture Assets.

See Also
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Texture Assets

Define texture channels for material assets

Description

Texture assets are image files that are typically used as texture channels for Material Assets.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

Image file types that RoadRunner supports:

* Bitmap (.bmp)

* DEM (.dem) — Typically used only for Aerial Image Assets or Elevation Map Assets
* GIF (.gif)

« GTX (.gtx)

e ICO (.ico)

 IMG (.img)

* JPEG 2000 (.jp2)

* JPEG (.]jpg, .]jpeg)

» PPM/PGM /PBM (.ppm, .pgm, .pbm)
* PNG(.png)

* RGB(.rgb, .rgba)

* SVG(.svg, .svQgz)

* TGA(.tga)

» TIF / GeoTIFF (.tif, .tiff)
 WEBP (.webp)

* X Bitmap Graphic (.xbm)

* X PixMap (.xpm)
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Attributes

Attribute Description

Default Width Default spatial size of the texture, in meters.
Used, for example, as the default sign size when
the texture file is used for Sign Assets.

Is Texture Atlas See Create a Texture Atlas.

Examples

Create a Texture Atlas

A texture atlas is a single texture image that contains multiple uniformly spaced sub-images, such as
this image.

{L I s

These are used as textures for Signal Assets and point markings. For more details on point
markings, see the Marking Point Tool.

To set texture atlas properties for a texture asset:

1 Select one or more texture assets in the Library Browser.
2 Select the Is Texture Atlas option in the Attributes pane.

Is Texture Atas |

3  Set the grid size of the texture (these specify the number of sub-image rows and columns) in the
Atlas Tiles option.
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See Also
Material Assets
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Vector Data Assets

Add GIS shapefiles and other vector data to scene for visual reference

Description

B OpenStireetidap
contributors

Vector Data Assets are used to add geographic information system (GIS) shapefiles and other vector
data to a scene, typically for visual reference.

Refer to Vector Data Tool for instructions on adding and adjusting vector data in your scene.

Creation

Create an asset outside of RoadRunner by using one of the supported file formats shown. Then, drag
the file into the RoadRunner Library Browser. For more details on creating, editing, and deleting
assets, see “Create, Import, and Modify Assets”.

Supported Formats

* Geo]JSON (.geojson, .json)

* GPS Exchange (.gpx)

* OpenStreetMap (.osm, .pbf)

» Shapefile (.shp, .dbf, .prj)

* Keyhole Markup Language (. kml, .kmz)

See Also
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